question

ken-nye6499 avatar image
ken-nye6499 asked Phong Vu commented

Use both HighVolumeSMS and Regular SMS in different APPs

I successfully created and am using the High Volume App on number xxx-xxx-1306
APP ID 0BeUP9IIQCSuO-LdU9dXQw

I then created another app to use regular SMS, I was trying to attach that number xxx-xxx-7873 or better yet our main 800#
APP ID 9TlxXxTiSf6n7qed0fX3uQ

When I try to login to the regular SMS production app with 7873, it does not work, but I can login to the online portal, so it is not a password problem. I cannot login with the 800# either, when I use the password reset for the 800#, it says it will send email to my email, but I never get an email. Also I dont see our 800# listed as a number in the users, and 7873 is the super user that I use to administer the account. I assume you cannot login as the 800#

Does something have to be done to allow me to use 7873 in the regular SMS app?

sending sms
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Phong Vu avatar image
Phong Vu answered

"When I try to login to the regular SMS production app with 7873, it does not work, but I can login to the online portal, so it is not a password problem"

1. "It doesn't work": how and what is the error?

2. "it is not a password problem": to login, you need the app client id, client secret, username, password AND extension number (if using the main company number). Any wrong the param will fail, NOT just the password.

Your 800 is a main company number and it's a TF number. TF number is not provisioned for SMS unless you create a request to enable for standard TF SMS feature.

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

ken-nye6499 avatar image
ken-nye6499 answered Phong Vu commented

thanks for the reply

1. the error when logging in with # 7873 is

 "error" : "invalid_grant",
  "errors" : [ {
    "errorCode" : "OAU-140",
    "message" : "Invalid resource owner credentials"

but I can login with that user/pass to ringcentral, I am extension 101 and have tried with and without the extension

2 I am using the client id, client secret, username, password AND extension number, just like I was in the sandbox, of course I am now using the production ID and Secret

    $SessionUser            =  "+15555557873"         
    $SessionPassword        =  "xxxxxxxxxxx"
    $ClientID               =  "xxxxxxxxxxxxx"     
    $ClientSecret           =  "hyGxxxxxxxxxnQ" 
    $sessionExtension       =  "101"

3. I created a request for the TF number
thanks

21 comments
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

"just like I was in the sandbox", did you really change the client id and client secret for your production app? Did you change the server url to point to the production server? I fully trust this error "Invalid resource owner credentials" and I am 100% sure it's a mistake in your params.

0 Likes 0 ·

I appreciate your concerns , here is my code for the production app

    $SessionUser            =  "+1xxxxxx7873"         
    $SessionPassword        =  "$xxxxxx!"
    $ClientID               =  "9Tlxxxxxxx3uQ"     
    $ClientSecret           =  "hyG_xxxxxxxxx_mjjnQ" 
    $sessionExtension       =  "101"

    $AuthAPI  = @{"endpoint"  = 'https://platform.ringcentral.com/'
                    "url"           = 'restapi/oauth/token' }

										

and here is the code for the sandbox

$SessionUser            =  "+1xxxxxx2434"         
    $SessionPassword        =  "j7MxxxxxxxxxAxf"
    $ClientID               =  "VRbXxxxxxxxxxKM_1Q"     
    $ClientSecret           =  "L4XAKxxxxxxxVY9g" 
    $sessionExtension       =  "101"

    $AuthAPI    = @{"endpoint"      = 'https://platform.devtest.ringcentral.com/'
                    "url"           = 'restapi/oauth/token' }

as you can see I have changed everything to use the production app

could you please verify that #7873 is configured to use this APP thanks for your time

0 Likes 0 ·

There is nothing wrong with your app. Since you login using the direct number, can you just drop the extension number param.

BTW, not sure how you finally call the endpoint, but your name for the AuthAPI is not correct. url or server_url should be "https://platform.ringcentral.com" and the endpoint is some endpoint such as "restapi/oauth/token".

0 Likes 0 ·
Show more comments

Something has changed in the backend, now I am getting a OAU-143

when I search for that in the forum, I get 0 results.


 {
  "error" : "invalid_request",
  "errors" : [ {
    "errorCode" : "OAU-143",
    "message" : "Resource Owner credentials are incomplete"
  } ],
  "error_description" : "Resource Owner credentials are incomplete"
}
0 Likes 0 ·

Developer sandbox tools

Using the RingCentral Phone for Desktop, you can dial or receive test calls, send and receive test SMS or Fax messages in your sandbox environment.

Download RingCentral Phone for Desktop:

Tip: switch to the "sandbox mode" before logging in the app:

  • On MacOS: press "fn + command + f2" keys
  • On Windows: press "Ctrl + F2" keys