Bill Frizzell avatar image
Bill Frizzell asked ·

Softphone installation not seeing my Office 2013 install

Upon installing the Softphone app, when the installation got to the integration with Office, it indicated that no Microsoft Office components were installed on my system. I have had Office 2013 installed (64-bit) for quite a while now. I can understand not yet supporting Outlook 2013, barely, but to state that it isn't even installed? When can I expect this to integrate as depicted? I have been a Ring Central customer for about 8 years now, and would like this to work at least as well as the previous versions.
softphoneoffice integrationoutlook 2013
1 comment
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Ben, SoftPhone flat out does NOT work with Office 2013. I have the 32 bit version (on x64 Windows), which is the default install and get the same message on every computer. After hours on phone support with RingCentral, I was told this is a known issue that RingCentral is working on. Your reaction here suggests it is not a very widely known problem...
0 Likes 0 · ·
kenneth-knightley avatar image
kenneth-knightley answered ·
Hey Ben.  We are a new customer to RingCentral.  Before selecting your service I was told RingCentral had a fully functional unified communications solution that was 100% compatible with Windows 8.1 Pr0 x64 and Office 2013 x64.  Now I am finding out none of this is true.  Your integration specialist, technicians and sales reps failed to get us integrated and mentioned our OS and software are incompatible.  It comes down to this - either this get's fixed asap or we move to another service.  I am 100% disappointed about this problem and expect it resolved.
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Bill B avatar image
Bill B answered ·
SOLVED: I had the exact same problem as others. I'm running Windows 8.1 64-bit with an Office 2013 32-bit installation, both of which are on the most current versions. And no matter how many times I tried to uninstall and re-install the Softphone (and I even re-installed Office!) the Softphone would say it could not detect my installation of Office. I SOLVED IT THIS AFTERNOON and here's how... The softphone is NOT looking in the right place to determine where Outlook is installed. I am assuming that it will only affect people (like me) who are running a 32-bit version of Office on a 64-bit Windows system. That would explain why it didn't affect everyone and why it may have been somewhat hard to re-create. I had to go into the Registry Editor (If you don't know how to get there, you should not try to do this yourself) and do some investigating. 1) First, I uninstalled the softphone and restarted. 2) Second, in the Registry Editor (after making a backup) I navigated to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\ 3) Next, I added a key called "Outlook" . 4) Within KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Outlook I added a key called "InstallRoot". 5) Rightclicking on InstallRoot I added a new string value called "Path" and set the value to the location on my computer where my installation of office lives (for me, C:\Program Files\Microsoft Office 15\root\office15). I then re-installed the Softphone, entered my account information, and it saw my Outlook just fine -- first try. My contacts are now synced and the add-in is present. ==NOTE== I actually added the keys as in steps 4-5 above multiple times. The location I listed above is the one that I think is most likely to have fixed the issue... If adding KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Outlook does not work try adding the same InstallRoot::Path to KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Common . If that doesn't work It's a fairly simple solution that should be able to be fixed by RingCentral's team by making sure the program is checking ALL of the appropriate registry keys. A 32-bit installation of office DOES NOT necessarily mean it's a 32-bit system, so you've GOT to check the registry redirector. ( Credit to this Stack Overflow post for getting me on the right track: And again, if this is WAY over your head, call your IT guy or hire someone. But hopefully RingCentral can roll this into an update and solve the whole problem.
3 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I was excited by this post and thought it would work. It sure feels like the right kind of solution, given the problem we're having. However, after uninstalling SoftPhone, I tried adding the Path string, value of "C:\Program Files\Microsoft Office 15\root\office15" (no quotes in registry, and confirmed that this is the right path on my 64-bit system for Office 365 32-bit) to both registry keys you referenced:



I then reinstalled the latest version of SoftPhone (ver During the initial setup, after entering my phone number and password, it sees the Outlook address book (same as always), and then still says that it can't find Microsoft Office, so it refuses to install any of the Office tools.

Do you see anything different in my keys from what you used?

In SoftPhone, if you click on menu | Options | Microsoft Integration, do you see a message, "Microsoft Office was not detected on your computer. To enable integration with Internet Explorer or Microsoft Outlook Express, please click "Advanced..."?


0 Likes 0 · ·

Could it be that it was one of the other changes you mention you made? I see there are similar keys in HKCU, for example. Did you also set those? Also, I notice that I have keys for several versions of Office (11, 12, 14, and 15), so maybe that's confusing it. Any idea if the SoftPhone installer is smart enough to know that only 15 is the current version of Office installed? I don't want to delete those other keys, because at least some appear to be from other apps related to but external to Office, like Lync, Visio, or MS Project, which are older versions.

0 Likes 0 · ·
Dangit.I seem to have broken the golden rule Changing more than one thing at once before checking if it's fixed... I'll get back to this this week and try to get an answer. Over the weekend I was not able to re-create the inability of the softphone to fail to connect. I have a busy couple days, but I WILL come back to this and try to figure it out!
0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces