question

rob-minialoff avatar image
rob-minialoff asked ·

WSAStartup failed WIN7

I just upgraded to RingCentral for Windows Desktop v7.30.010.00 from RingCentral Softphone 6.04.001.50 (64-bit) because when I started softphone it told me there was an update.

 When v7 starts it comes up with an error window that says: "Either the application has not called WSAStartup, or WSAStartup failed"

I also found that there is a newer version of 7 (7.3.2) available for manual download from ringCentral.  This also fails with the same error.

I note that while I have a 64 bit system and the previous sofphone app (v6) says it is 64-bit and taskmanager shows it as RCUI.exe and is running 64 bit, the new v7 app installed in Program Files (x86) and is running Softphone.exe as 32 bit.

The previous v6 softphone app is still installed (it was not removed by the v7 installer) and still works when I run it.

Any ideas?

topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mike avatar image
mike answered ·
Hi  Rob Minialoff,   If you are still having problems, try as Danno suggested and completely remove/uninstall the previous version.  If you still have problems, let us know. 

Mike 
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

rob-minialoff avatar image
rob-minialoff answered ·
I have done that with the same result, AND now I don't have a softphone because I don;t have the v6 installer that works.
1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

You are probably best served by opening a ticket with tech support since they would have access to more information about your account than those of us in the community.
0 Likes 0 · ·
mike avatar image
mike answered ·
Rob, I agree with Danno. You probably want to contact tech support (perhaps live phone support) and have them help you out over the phone.  The old Legacy phone v 6.0 will be retired by November 1st so it will just cause you more grief if you reinstall it. Our support team can help you get one of the 7.0+ versions working for you. 

Mike
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

rob-minialoff avatar image
rob-minialoff answered ·
I entered a support ticket 3 days ago with level 2 urgent status (I have no business phone as a result of this problem) and I have not heard a thing except the confirmation email message saying I would hear from Support within 24 hours.  "A RingCentral Technical Support Specialist will respond to the case that you have created with a reference number of 03939797 within 24 hours."  Yah right!
1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

reaching out to that team now... Thank you
0 Likes 0 · ·
danno avatar image
danno answered ·
I have not upgraded to 7.3.2, since there are numerous issues reported in the Community with it, but when I updated to 7.2.4.15096 (earlier in the year), I had issues with that too until I totally deleted the previous version from my PC, then did a new upload.  Since that, it has operated flawlessly.  That would be my suggestion.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces