question

butler avatar image
butler asked ·

iOS mobile app not giving me the opportunity to answer calls

I'm in the U.S., using the latest iOS (9.2.1) on an iPhone 6, and the latest RingCentral app version.  I am on the ProPlus plan.

The problem is when an incoming call is received through the RingCentral mobile app, I cannot seem to answer it.  When I see the notification, launch the screen, unlock (if locked) and otherwise try to answer, the incoming call will either not show up at all (just brings me straight to the messages screen), or the call pop-up will appear for a split-second before sweeping away.  Neither of which gives me an opportunity to answer the call!

All of this can happen in as little as a few seconds, when I have my settings set to ring for 30 seconds.  On occasion I have managed to quickly hit "Answer" when the call pops up, only to see it swiped down with no effect.  It is very odd to see a missed call occur after only a few seconds of ringing and my attempt to answer it.

I have gone through my settings and everything seems in order.  The only way I've been able to answer calls is if the app is already open.  In this age of phones locking themselves after being idle for 1 minute or less, this seems very unrealistic.  How can this be fixed?  Thank you.
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

danno avatar image
danno answered ·
Same thing was happening to me when I first got the service - and I figured out what was happening.  Hope this helps.  I had the APP open on my iPhone and my phone was locked.  I'd hear the hear Miramba code, unlocked the phone, and there was no call.  So I figured out that if I touched the APP icon, there was the call.  Again - hopes that helps.
 
5 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I appreciate your response Danno and sorry if my OP was unclear, but to clarify, I always open the app to attempt receiving the call.  However way I do it (tapping the icon or swiping from the locked screen), the result is the same - the app seems to pretend there is no call and then seconds later I will see the call as missed.

On one of my call tests, I even got the text message notifying me of a missed call... while the incoming call was still ringing!  I sincerely hope there is a more concrete solution to this.
0 Likes 0 · ·
Are these calls coming to you directly or through a call queue? If through a call queue, then you must press 1 to connect the call on your cell phone. You can disable it for direct extension calls (Call Handling & Forwarding > Incoming Call Information > Play Announcement).  We see this a lot where when you answer it, the system immediately says "press 1 to connect" but by the time you put the phone up to your ear after swiping, you can miss the prompt. Try that and let me know. 
0 Likes 0 · ·
Hi Kim, the calls are coming directly - to the RC iOS app.

I'm not experiencing the system prompt you describe.
0 Likes 0 · ·
We'll need to gather a few more details. 

1.  Does this occur on every call?  How long has this been happening? 

We are in the middle of pushing our an update and your account has recently been updated. Have you already tried to uninstall and reinstall the mobile app? 

2. I see there is a forwarding number (ending in 9336) set up. Is that the cell number for the same phone?    Does it forward and ring the phone direct?  Or does it go to voicemail?

You may want to try and momentarily turn off the forwarding and test it again, just to see if it's related to that.

Mike  


0 Likes 0 · ·
Hi Mike,

1.  It's unclear to me how long this has been going on.  I'd say at least several months, possibly longer.  I have tried uninstalling and re-installing the mobile app.  It occurs on the vast majority of calls.

2. Apologies for the confusion, but I re-activated that forwarding number this afternoon because I was trying to figure a work-around until this issue is solved.  Before today, call forwarding has always been off, and I prefer it with call forwarding turned off.

To clarify, I am trying to answer incoming phone calls in the RC app.  While ringing, I open the app, and suddenly there is no call and no means to answer it.
0 Likes 0 · ·
phil-koorsen avatar image
phil-koorsen answered ·
Hello,

Concerning your issue with the iPhone and Mobile app. What do you have your First Ring feature set to? By default it is set to 1 ring (5 seconds). You stated that ringing is set to 30 but is that 30 seconds in the First Ring area or in your call handling for your desk phone? 

If you have not done so, try setting the number of rings to 30 seconnds in the First Ring feature and test. 

If you have already done so but get the same issue, set the number of rings in the First Ring feature to 0 and this will make it ring simultaneously with your desk phone and test. Let me know the results. 
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

butler avatar image
butler answered ·
Hi Phil, My First Ring feature is set to "Desktop apps & Smartphones" and is indeed set for 30 seconds, and has been for as long as I remember. I've never had a desk phone or used any call handling settings to desk phones. For what it's worth, I have discovered that I can answer incoming calls through the iPhone app when those calls come from other VOIP lines (such as Google Voice), however my original issue persists when incoming calls come from a standard mobile- or land-line, and continues to be just as I described in the OP.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

phil-koorsen avatar image
phil-koorsen answered ·
Thank you, I investigated your issue and recommend that you call our tech support to open a ticket and it should be escalated to our T3. Also, go into your mobile app, click on your Profile and select the 'About' and use the 'Send Feedback' option to send the log that the app keeps. When you create your support ticket, include the date, time, and email for when you used the 'send feedback'. Our T3 is aware of this issue and will  investigate and notify you with status and a resolution.

Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

butler avatar image
butler answered ·
Thank you Phil.  I have created a case - #04393264 - and sent the logs.

Looking forward to solving this matter.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

kim avatar image
kim answered ·
Butler - just checking in...how are things going on your case? 
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces