question

eric-l avatar image
eric-l asked ·

Desktop App: Issues with Supported Headsets

US RingCentral Office Enterprise

We're in the process of transitioning our agents from desk phones to the RC Desktop App for Windows.  We're running Win10Pro, and our agents are using either the Plantronics Voyager Pro UC, or the Legend UC.  I previously used the Pro with the softphone and didn't experience many issues; the only problem seemed to be that the call controls on the headset wouldn't work, but this is due to the fact it's not a supported headset.  When a few of us switched to the Legend, we started noticing some issues.

  1. All four of us who are using the desktop app right now are also using the Legend.  We seem each to be having static issues occur intermittently throughout the day.  Our work stations are set up so that the Ethernet cable runs from the wall, to the phone, then to the computer.  We're about to do some renovations to our office including re-wiring all of our Ethernet cables, and we intend to have the phones & computers on separate routers.  I've heard that this can make a huge difference, so I'll wait & see with this issue, but I wanted to make you aware of it.
  2. One agent is experiencing issues where her headset will occasionally auto-answer an incoming call, even though that setting in RC & Plantronics is turned off.  She also has a delay between when she takes a caller off hold and when they can hear her talking, usually about 2-3 seconds.
  3. When I first started using the Legend, I was able to answer & end calls using the call button on my headset.  In the past week or so, I've no longer been able to do so.
Do you have any ideas what might be causing the issues mentioned in #2 & #3?
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

· Write an Answer
mike avatar image
mike answered ·
HI  Eric L

First... Just an FYI... Windows 10 is not yet supported so there may still be some quirks such as these. 

However, what you've described in both 2 & 3 actually sound like issues with the headset. 

For #2 what model of headset is this user using? Is it one of our tested/recommended models? 

For #3, This sounds like the Plantronics Hub Software may need to be installed. The call controls on the device won't work unless the software is installed. 

Mike 
10 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for the quick reply Mike!  I've heard that Win10 isn't supported yet, but thought this might be more related to a network issue rather than the operating system.

All of us who are currently using the Desktop App are using the Plantronics Voyager Legend UC, and we all have Plantronics Hub installed.

Which settings need to be set/changed in the Hub so that I can get my call controls working again?  I've not changed them since I first installed the Hub several months ago, but the call controls stopped working about a week or two ago.  I just updated to the latest version a couple of days ago, and that unfortunately didn't fix the problem, so I have no idea which settings to change.

Thanks again!
0 Likes 0 · ·
Hi Eric,  Do you by any chance have a Win 7 or 8 machine you can test the device with to see if it's isolated to the Win10 machine?  

If it worked a few months ago, but then stopped, it makes me wonder if it's related to the Win10 OS, as they've pushed out several updates over the last few months.  

Mike 
0 Likes 0 · ·
Unfortunately, we do not have a Win7 or 8 computer; everybody got upgraded to Win10 in the middle of July.

And again, the call controls only stopped working maybe a week or two ago.  Furthermore, I'm the only one experiencing this issue with the call controls, just like the other agent is the only one experiencing the issues I mentioned in #2.
0 Likes 0 · ·
Hi Eric, 

I've done a substantial amount of reading and research on this. There are several variables here. The RingCentral Desktop app, Win10 OS, and of course the Plantronics device/hub software. 

1.  Can you first make sure that you and your users are on the latest version of our Desktop app which is 8.2.1 at this time and test again if anybody is on an older version.

2. According to the Plantronics support site there have been several software releases which address a wide range of issues.  You may want to check with Plantronics to see if there are aware of these specific issues ranging from radio problems, usb 3.0 issues (try a different usb port, or usb cable), and more.  

3.  If there's not a solution then please open a support case, or reply back here, with the following info so we can open a case for you. 

In your notes include the following info for each user: 

  • Phone number each user is logging in with
  • The Plantronics device model and what software (hub software version) is installed
  • The exact Win 10 OS build version. (there have been several releases just in July and August)
  • And the symptom/problem for each combination listed above. 



0 Likes 0 · ·
Thanks Mike!  Turns out that my issue with the call control buttons was due to the fact I remotely connected to my computer two weeks ago.  It seems that in doing so, the Plantronics Headset switch in the RC Desktop App settings was turned off.  After turning it back on, call controls started working as usual.

As far as the call quality issues go, we've decided to try to wait until we get our office rewired.

However, do you have any ideas what might be causing the delay I mentioned in #2?  And what are the recommended settings for Plantronics Hub?

We've also noticed that the range of the Bluetooth seems to be less when the USB dongle is plugged into our computer, versus plugging it into our VVX 500 phones.  When plugged into the phones, we could pretty much walk freely around the office without issue.  But once the dongle is plugged into the computer, we need to be near our desk, and sometimes it starts getting static simply by looking in another direction.  Any ideas about this?
0 Likes 0 · ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces