question

chad avatar image
chad asked ·

Unable to answer call on Smartphone when Desk Phone disconnected

Note: I am posting this as Private simply to be confirmed before opening up to the community.


I believe I recently encountered a bug when my office lost our internet connection.

My simple setup consists of 3 users,  all with primary desk phones.  Two users use smartphones for backup or intermittent use (not always signed in).

My Call Routing Settings:
First Ring > Desktop & Smartphones (On) > Wait "0" Seconds before transferring to desk phones.  All phones ring Simultaneously.

Under normal operation, all desk phones and signed in smart phones will ring simultaneously as intended and calls can be answered by either desk phone or smart phone.

With this setup we expected that during an ISP or power outage, desk phones would be disconnected, but calls should continue to ring the Smartphones as usual.

------------------------------------------------
However, during a recent internet outage we found that we were unable to answer the call via the Smartphone app.  Desk phones had obviously lost connection... incoming calls ring on the smartphone, but pops up for only a split second before going away, repeating until it goes to voicemail.  Since the call only pops up for a split second, we are unable to answer the call. Once the office internet connection is restored and desk phones are operational, the smartphones then ring and can be answered as normal.
--------------------------------------------------

This was later repeated in a simulated internet outage by disconnecting the modem.

I was able to work around this issue by changing the Wait "0" Seconds Before Transferring  to "5" seconds.  The incoming call would then display on the smartphone for 5 seconds, still disappearing in 5 second ring interval loop, but this now allowed enough time to answer via the smartphone.


I see that there is a recently released setting for "Forwarding for Unreachable Phone", but this can not be used when First Ring Desktop & Smartphones is set to On.   Regardless, I would see this only as a workaround and not a solution.
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

saadet.swift avatar image
saadet.swift answered ·
Hello Chad,

On the mobile app, what do you have listed under the Call Settings? Below are the options currently. Also, are you using an iPhone or an Android?




Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

chad avatar image
chad answered ·
Hi Saadet,  thanks for the quick reply.

Both smartphones and Android.  Same settings as above, but the Android app doesn't have the "Integrated Calling" setting listed on that page.

An important detail that I forgot to mention is that I found I had the exact same symptom from a desktop PC installed soft phone.  So I don't believe it's an issue with the smartphone app settings.  And this is why I focused more toward the RC call handling settings.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

saadet.swift avatar image
saadet.swift answered ·
Hello Chad,

The PC that the softphone was logged in on, did it have internet connection? If so, was it WiFi or a hard connection?
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mike avatar image
mike answered ·
Hi Chad,  To us, it sounds a little like the mobile app isn't switching over to data when the local network/wifi goes down.  Here's a screenshot from an Android.  Do you have the 2nd button selected?

Depending on the reason the internet goes down, or what piece of equipment is down, your mobile devices might still be receiving a signal, from the router, but, with no internet.

Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

chad avatar image
chad answered ·
Saadet,   PC was connected through a LTE hotspot at that time due to the main ISP outage.

Mike,   The smartphones were set to "Always use VoIP" and experienced no change whether the device was connected to the wifi router  -or-  with the Android device's Wifi turned off and only a LTE connection... thus eliminating the local network as the issue.
4 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

What about the 2nd button?   If that button is selected, it won't work when on data.
0 Likes 0 · ·
I will test that as soon as I get a chance.  Most likely tomorrow afternoon.  Thanks.
0 Likes 0 · ·
Hi Chad,  Just following up to see if you had a chance to test it again and look at that setting above?  Let us know if you need anymore help.

Mike
0 Likes 0 · ·
Thanks Mike.  Sorry for the delay.  Unfortunately I only have a narrow window of time to do the testing at the end of the work day, since it requires disconnecting our modem to simulate.

Though, I am still slightly confused why you think this will solve the problem. Perhaps some miscommunication here or I didn't provide enough information?

Turning on "Use VoIP only on Wifi" won't ring the smartphone while on data (wifi off) as you said above.  However, that would be the opposite of what I want to accomplish.   My goal is to allow incoming calls to ring the smartphone app when there is no WIFI connection available.

Never the less, I did try the "VoIP only on Wifi" yesterday and I did not get any ring at all to the smartphone, as would be expected.


0 Likes 0 · ·
chad avatar image
chad answered ·
So after testing with the "Use VoIP only on Wifi" (with modem disconnected and Wifi off) setting and not getting the desired result...  I switched back to "Always use VoIP" and then I no longer experienced the odd behavior that I was having before  of not being able to answer the call.  You can imagine the frustration!

My simulated test and all settings on the smartphone and RC seem to be identical to when I previously experienced this problem, but I got a different result.  Yes, this is the desired result, BUT I'd still really like to find out what triggered it in the first place.

I will continue testing when I can and keep you guys updated with what I find.

Again, thank you guys for your time and assistance!
1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hey Chad, 

Thanks for the update. It sounds like for some reason your phone was stuck on thinking it should use WiFi instead of switching over to data use. That's the only thing I can think of. But let us know what more testing brings!

Also, what version of the mobile app are you on?
0 Likes 0 · ·
chad avatar image
chad answered ·
And once again, the moment that the desk phones reconnected... the smartphones and desktop soft phone began to operate as normal.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces