question

william-smith7233 avatar image
william-smith7233 asked ·

iOS11 Camera access

I'm seeing an error when activating video for a meeting that says the following:

Unable to access camera

This app does not have access to your camera. You can enable access in Privacy Settings.

I have checked Settings > Privacy > Camera and I do not see Meetings in there - I do see Ring Central, which has camera access.

I am running Meetings v 5.1
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

luke2909 avatar image
luke2909 answered ·
Hi William. I think the fist thing to try would be resetting the RingCentral app's permissions for the Camera.

First I would try turning off the RingCentral app's permissions for camera in the Settings > Privacy > Camera you mentioned earlier. Then open the RingCentral app again. Then I would restart the phone, and reopen the RingCentral app to re-enable the camera access and test.

If this doesn't work the app may need to be deleted, then restart the phone, then re-download the app and try the camera again.

If these steps don't work then I would request that you get the diagnostic logs from the RingCentral app and open a case with us so we can investigate the issue further. We have a page showing how to get the debug logs on the mobile app . Once you have the debug logs you can create a case and attach the logs at http://success.ringcentral.com/RCContactSupp.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mike-hou573 avatar image
mike-hou573 answered ·
This is a bug and we will fix it next release which is coming around Dec this year.
1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Mike,

While I haven't found William's post to be an issue for me, I do find that Meetings is NOT showing under Background App Refresh in iOS11.1. So whenever I start the meetings app, it advises me to turn on Background App Refresh so that it can advise me about upcoming meetings.

I have background refresh turn on for WiFi & Cellular and the Mobile app and Glip both show in the Bacjground App Refresh listing of apps but the Meetings app does not.

I don't know if that is also a part of the bug you are referring to but if not, it seems to be an additional bug you may want to know about.

1 Like 1 · ·
J.B. Ferguson avatar image
J.B. Ferguson answered ·
William,

I realize that Mike Hou stated that this is a bug however, when I switched to iOS11 from iOS10.3 I had no such issue and when I again upgraded to iOS11.1 this morning, again that has not been an issue. Not only is RIngCentral Meetings showing under the Settings > Privacy > Camera but I have never not had the camera show up when starting a meeting. I am running the most recent version of RingCentral Meetings as well as the most recent iOS operating system.

If you haven't tried Luke's suggestions I recommend that you do. It might just solve your issue.

Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

william-smith7233 avatar image
william-smith7233 answered ·
Lets be sure were on the same page here. This issue is with RingCentral Meetings (RCM), not Ring Central (RC). RC has no camera component as its a soft-phone manager and not a meeting/screen sharing tool. Attached is an image of my privacy settings, no RC or RCM. I will try to reinstall RCM.
4 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I wouldn't have posted if I didn't understand what you were saying or if I didn't know what I was talking about. Yes....same page of music. I am a RingCentral Partner/Reseller. I know my products. See my screenshots.



0 Likes 0 · ·
Also, per my post to you, "Not only is RIngCentral Meetings showing under the Settings > Privacy > Camera but I have never not had the camera show up when starting a meeting. I am running the most recent version of RingCentral Meetings as well as the most recent iOS operating system."
0 Likes 0 · ·
Hi Jan, I see your screenshots and you see mine; I am glad you know your products. You have said it's always worked for you, which is fantastic, however I'm not having the same luck and have tried Luke's suggestions of resetting camera permissions for RingCentral and restarting my device.

I have also reinstalled RingCentral Meetings on my iPad Air. As an additional note, I also have an iPhone SE running iOS 11 with RC and RCM installed and neither application appears under Settings > Privacy > Camera.

I am going to wait until December, per Mike Hou's post as it appears it's a known bug in iOS 11.
0 Likes 0 · ·
At least you tried Luke's suggestions. It's not a matter of being happy it works for me, it should work for you and I have no idea why it works for one person versus another. If it's a bug like Mike Hou said, why isn't it affecting me. Software can be perplexing.

FWIW, I'm sorry if I came on a little strong in my post. After I mentioned RingCentral Meetings three times I felt taken back a might when you still wanted to make sure we were talking about the same thing. I post here to help other users of RingCentral products, not to lead them down the wrong path.

Meanwhile I found another possible bug which Mike and his team may not have been aware of. Hopefully his team can get these resolved as quickly as possible.
1 Like 1 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces