News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Search
Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
Cannot log into RingCentral softphone for windows
Tags: developer sandbox
Aug 31, 2020 at 4:20pm   •   5 replies  •  0 likes
Josie Li

Hi there,

I'm new on RingCentral. My company is currently building a CC solution on RingCentral. I created a free account using my business email address and created a free sandbox using this account for proven of concept work. I can see RingCentral auto assign an ext "101" to it but no phone associated with it. So I went to phone system to add a Ringcentral soft phone to it. Then I tried to log into the softphone on my desktop using my email address but it failed saying "Sorry, you currently don't have permission to access this service. Contact your administrator to change permissions. ". What I need to do for me to successfully log into the softphone?

5 Answers
answered on Aug 31, 2020 at 5:06pm  

Thank you for the quick response! I tried and failed. This is what I did following your instruction:

  1. Go to "Sign in" screen
  2. At the point I'm going to enter password, I pressed Ctrl + F2
  3. The toggle did not come up

 0
answered on Aug 31, 2020 at 4:49pm  

By default, it uses production mode. You need to log in in Sandbox mode

From the softphone sign-in screen use the following key combination to bring up the Sandbox environment toggle:

  • Windows user: Cntrl+F2
  • Mac user: Fn+Command+F2

 0
on Nov 28, 2022 at 6:23am   •  0 likes

What about linux users?

answered on Aug 31, 2020 at 5:45pm  

It looks like I have to use phone App


 0
answered on Sep 1, 2020 at 3:29am  

Yes. I figured out: you have to install RingCentral phone app which supports sandbox. Hope it helps


 0
answered on Sep 1, 2020 at 2:11am  

We've got exactly the same problem and means we can't test anything. Did you get this working on mobile as I get a permission error on that as well?


 0



A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

PRODUCTS
RingEX
Message
Video
Phone
OPEN ECOSYSTEM
Developer Platform
APIs
Integrated Apps
App Gallery
Developer support
Games and rewards

RESOURCES
Resource center
Blog
Product Releases
Accessibility
QUICK LINKS
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us