"open ringcentral" prompts everytime I dial a number in Salesforce in google chrome

  • 0
  • 2
  • Question
  • Updated 1 month ago
  • In Progress
  • (Edited)
Everytime I dial a phone number in Salesforce , google chrome asks for a permission . It is very annoying . Anyway I can get rid of this??
Photo of Taranbir Singh

Taranbir Singh

  • 130 Points 100 badge 2x thumb

Posted 2 months ago

  • 0
  • 2
Photo of Saadet

Saadet, Employee

  • 67,992 Points 50k badge 2x thumb
Hey Taranbir, could you provide step-by-step guide on how you're calling out and when you get this message? Screen shots are always helpful and appreciated :)
Photo of Taranbir Singh

Taranbir Singh

  • 130 Points 100 badge 2x thumb
I call from numbers directly by click to dial feature in sales force, earlier it just dialed the number in ringcentral, but now it asks for a permission first. I can't provide the screenshot in public.
Photo of Saadet

Saadet, Employee

  • 67,992 Points 50k badge 2x thumb
Hey Taranbir, you can blur out information you don't wish to show. But if you don't feel comfortable at all, I would suggest calling Tech Support so that they can do a screen share and see what you're seeing
Photo of Ian Carswell

Ian Carswell

  • 80 Points 75 badge 2x thumb
I am experiencing the same problem.
Steps.
1. Click to dial a number in Salesforce
2. The soft phone utility pops-up
3.  Chrome displays a message  "Open RingCentral Phone"

Photo of Taranbir Singh

Taranbir Singh

  • 130 Points 100 badge 2x thumb
yes same problem as me

Photo of Kellie Babb

Kellie Babb, Official Rep

  • 120 Points 100 badge 2x thumb
Hello Ian and Taranbir, 

Thank you for the additional information. Can you please confirm if you have the RingCentral Phone app launched and signed into on your desktop when you are attempting to make these calls through SalesForce?

If you don't, please ensure that you are signing into your desktop application in addition to SalesForce and let me know if you continue to get the pop up. 

Thank you,
Kellie B.
Photo of Nadia Grabiner

Nadia Grabiner

  • 60 Points
I'm having the same problem, as is my team. We are signed in on the desktop app. 
Photo of Taranbir Singh

Taranbir Singh

  • 130 Points 100 badge 2x thumb
Yes I am also signed in on desktop App
Photo of Ian Carswell

Ian Carswell

  • 80 Points 75 badge 2x thumb
Yup, I am signed into the desktop App.
Photo of Lee

Lee, Champion

  • 3,244 Points 3k badge 2x thumb
We are experiencing this also. It is a Chrome issue. they took away the check box to always open these types of links in the associated app in version 77. https://support.google.com/chrome/thread/14194567?hl=en 
Photo of Saadet

Saadet, Employee

  • 67,992 Points 50k badge 2x thumb
Thanks for sharing, Lee!
Photo of Allison Mohr

Allison Mohr

  • 70 Points
Wow! So we won't be able to get rid of that?
Photo of Lee

Lee, Champion

  • 3,244 Points 3k badge 2x thumb
Not until the great and powerful Google decides to change it. I've had the users affected, switch to firefox for now. 
Photo of Ian Carswell

Ian Carswell

  • 80 Points 75 badge 2x thumb
Please can you provide instructions on what values we can add to the Chrome preferences JSON to address the problem. As described in:

https://support.google.com/chrome/thread/14194567?msgid=15347344

Photo of Allison Mohr

Allison Mohr

  • 70 Points
WORKAROUND: Download the Google Chrome RingCentral extension. Then instead of using click-to-dial, hover over the phone number and click the phone option. Works for me. No more pesky pop up every single time I dial.