Add Pauses and #s in Contact Numbers.

  • 6
  • 142
  • Idea
  • Updated 1 year ago
  • Implemented
Would like to see the ability to add pauses and #s into pone number for dialing extensions and initiating actions.

For example:

  • I want to call a contact, but have to go through an Auto Attendant first. In the past I've been able to add their phone number like so: (888) 555-2345,,3232. This would call the number wait for 3 seconds then enter the extension number.
  • The 2nd type of dialing is conference calls. Most of them have long PINs to access the bridge. I would typically copy and paste something like this to dial: (888) 555-2345,,7196453672# where the two commas pause for 3 seconds then enter the PIN then press enter to initiate the login.
Most mobile phones have no problem with this, however, the mobile app (and the VoIP handsets) don't seem to have the ability to add this to contacts, or accept them if you try to copy and paste them for dialing.

Photo of Eddie Forero

Eddie Forero

  • 3,904 Points 3k badge 2x thumb

Posted 6 years ago

  • 6
  • 142
Thanks again, the asterisk (*) pauses worked for my Call Forwarding application.  I haven't tried contacts as I don't use them.
Photo of Carlos Henriquez

Carlos Henriquez

  • 144 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Easy Dial with RC Desktop app.

Hi!
It will be helpful if Ring-Central allows Commas as pauses so then we can add our users ID to make it easier to dial-in a conference call.
I tried simulating this scenario and RC only picks up the First Tel Number anything after the first comma gets omitted.  
is someone else having this same issue?
I just want to be able to add a number such as 2679999999,,,,,,123123123#
where 267 is the conf bridge and the 123123123 is the users conf ID.

Please look into this, it will be so helpful.
Thank You
Los
Photo of Mike

Mike, Official Rep

  • 94,158 Points 50k badge 2x thumb
Official Response
Customers can copy the entire meeting dial-in sequence froma meeting invite and either:
  • Paste it into an existing contact’s info
  • Create a new contact and paste it as the phone number
  • Paste it into their keypad to place a call
The system recognizes the following symbols as functions:


, as pause
* as star
#  as pound
Photo of Brandon

Brandon, Champion

  • 24,738 Points 20k badge 2x thumb
This reply was created from a merged topic originally titled Added pause support during dialing.

Has anyone discovered how to add pauses in a dial string on the desktop app?  I tried commas and semicolons and the letter "p".  I can't seem to find any reference to how this new feature is intended to work.

Photo of Danno

Danno, Champion

  • 28,512 Points 20k badge 2x thumb
Hey Brando, I was able to get it to work on the desktop app.  For example, I added a contact for my conference bridge (2679304000,xxxxxxxxx#) and it worked.  But, it only works for direct dial - not ring out.
Photo of Danno

Danno, Champion

  • 28,512 Points 20k badge 2x thumb
FYI, sadly, when I made the contact a favorite, it no longer works.  But works outside of favorites. 
Photo of Christopher See

Christopher See

  • 82 Points 75 badge 2x thumb
I am experiencing the same thing as Danno.  When I try to dial from my favorites, it says it's an invalid number.
Photo of Brandon

Brandon, Champion

  • 24,738 Points 20k badge 2x thumb
Same.  I can create a contact with commas and it works, but not from favorites.  Let's all report this through the app and it should get some visibility to get fixed.
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hey everyone!

I've confirmed with our Product Team that this is a bug we are working on to fix in the 9.4 release. 
Photo of Doc Watson

Doc Watson

  • 162 Points 100 badge 2x thumb
Is this going to be fixed in the RingCentral for Lightning App? Without it it's a real pain.....
Photo of Doc Watson

Doc Watson

  • 162 Points 100 badge 2x thumb
I just confirmed via support chat that this is STILL NOT SUPPORTED! That is crazy! I have thousands of contacts stored with the standard commas as pause format and the dialer not only doesn't support the pause, but it aborts the call! The only way to use it for this at all is to  copy/paste the number into the Windows app, WHICH IS CRAZY! hALF THE REASON i SWITCHED TO THIS PHONE SYSTEM HAS BEEN ELIMINATED WITH THIS ISSUE! Please add this common feature ASAP.
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hey Doc Watson, sorry for the frustration! I've forked this to its own feature request since our Salesforce Dialer is separate from our Softphone application

Please reference the new conversation here: Allow Pauses and #s in Contacts for the Salesforce Dialer
Photo of Michelle Tyler

Michelle Tyler

  • 78 Points 75 badge 2x thumb
This feature still can't be done from a deskphone or conference phone!  So incredibly frustrating.

Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hey Michelle, could you specify what you are not able to do? I was able to add a contact on my desk phone that included main company number + extension number and it routed to the correct person when dialed.
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Team, I thought this was resolved, as I know when using an * it has worked for me.  I cant get any of the pauses to work when setting up a speed dial to other companies to select an option in their IVR

Anyone have this working?
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Are you setting this up on a desk phone or a softphone? 
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Setting up a virtual extension as a speed dial
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hmmm....I was able to set up a speed dial for an IVR. This is how I did it: main company number*1002 (which is my IVRs extension). Are you receiving an error message when trying to call?
Photo of Michelle Tyler

Michelle Tyler

  • 78 Points 75 badge 2x thumb
setting this up on a Polycom ip 6000 conference phone.  Apparently it doesn't support pauses and it is a Polycom limitation.  Wanted to set a speed dial for a conference bridge, then set a pause then enter in the bridge #. 
Photo of Matthew Burt

Matthew Burt

  • 204 Points 100 badge 2x thumb
This is broken for the Google Authorization in softphone extension. When I put commas into our contacts and add extensions it strips out the commas and just has a long number which leads to a busy signal when dialed.
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hey Matthew, do you have an example you could share? 
Photo of Matthew Burt

Matthew Burt

  • 204 Points 100 badge 2x thumb
An example would be creating a user named John Smith with 555-555-5555,,123 as the contact number in google contacts. I open my RC softphone through the chrome extension and authorize Google which lets me search Google contacts. I then search for John Smith and his number comes up as 5555555555123 with no commas. This means the comma pause function doesn't work and it also means that ring central doesn't even actually dial the number (I just get a busy signal).

Commas represent pauses (2 seconds per comma) which allows you to enter extensions in a contact number.

I got with RC support and they told me that google saves it this way on their servers. This can't be true, since leaving the contact and coming back still has the commas in place in google contacts.

Having said that, I could see a situation where Google strips out all non-numeric characters when passing numbers along through their API. I'm not saying this is the case, just simply the only way I can make what RC support said make sense in my brain.

This sucks.
(Edited)
Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hey Matthew, I see. I didn't realize you were using the Chrome Extension. At this time the Chrome Extension does not support this feature, unfortunately. I have brought this up to our Product Team and they are taking it into consideration :) 
Photo of Matthew Burt

Matthew Burt

  • 204 Points 100 badge 2x thumb
Thank you. Our entire company uses chromeboxes. We have a windows server we can RDP into, but most everything we do is ChromeOS/extensions/SaaS cloud apps
Photo of Bob James

Bob James

  • 60 Points
Using * * rather than comma's worked for our needs
Photo of Matthew Burt

Matthew Burt

  • 204 Points 100 badge 2x thumb
The issue here is that no special characters make the trip between google contacts and ring central (at least not on the chrome extension) so , or * disappear. Commas push the numbers together and never dial. Asterisks make everything after it disappear as well.
Photo of Tony Russo

Tony Russo

  • 60 Points
Using Outlook App v 1.16.2 (installed today).

Using the dialer in Outlook I wish to either copy and past or type in a phone numbers containing commas (,) or star (*) or hash (#). 

Does not allow me to enter or copy and past into the dialer phone number containing commas.

Photo of Saadet

Saadet, Employee

  • 68,082 Points 50k badge 2x thumb
Hi Tony, the Outlook Integration doesn't support this functionality currently so I've forked your thread to its own separate feature request for others to vote on

Please reference the new conversation here: Outlook Dial Pad - Support Phone Numbers that Include Special Characters