Android app adding 1 to the beginning of called numbers

  • 0
  • 2
  • Question
  • Updated 1 month ago
  • Answered
I've recently started using the Android RingCentral app.  Calling mode is Direct Dial, not Ring Out.  I am in the UK, and both my RingCentral and mobile numbers are UK number.  When I dial a UK number, the app is putting a 1 at the start of it and it sounds like it's trying to dial an international number.  Dialing an internal extension is fine.  I assume this is something to do with regional settings but I can't find an option to change anything that would appear to affect this.  Can anyone help?
Photo of Emily Graham

Emily Graham

  • 112 Points 100 badge 2x thumb

Posted 1 month ago

  • 0
  • 2
Photo of Robert Incorvaia

Robert Incorvaia

  • 300 Points 250 badge 2x thumb
I had this issue on my Android.  Fixed it by going into the mobile app Settings.  Then look for Android phone number.  The system seemed to incorrectly save my cell number.  When I corrected it, all was better.  Hope this helps.
Photo of Emily Graham

Emily Graham

  • 112 Points 100 badge 2x thumb
Thanks for the quick response.  That didn't work, unfortunately, I still have the same issue. 
Photo of Tyler D

Tyler D, Employee

  • 566 Points 500 badge 2x thumb
Hi Emily, 

Thank you for contacting RingCentral.

This probably has to do with the Regional settings within the app, we have two mobile apps that can make calls: RC Phone (just the phone) and RingCentral (the unified chat/meetings/phone app) I'll post the steps to change the region for both Android apps: 

RC Phone
  1. Tap your profile picture in upper left hand corner  
  2. Select Mobile App Settings  → Region
  3. Select your correct country 
  4. Make a test local call 
RingCentral App
  1. The three lined "Hamburger" Icon in the upper left 
  2. Select Settings  → Region 
  3. Select your correct country 
  4. Make a test local call 
If you are still experiencing issues please call our main support line at 0800 014 8091. 

Hope that helps. 

All the best,  

Tyler Dickey | Tier II Technical Support Engineer—EMEA
Global Services & Solutions
Connect with me:
0800 014 8091 (within the United Kingdom)
+44 20 3514 9006 (outside the United Kingdom)
support.ringcentral.co.uk



(Edited)
Photo of Emily Graham

Emily Graham

  • 112 Points 100 badge 2x thumb
Thanks for the reply but I'm using the RingCentral app and there is no 'Region' option in the Settings menu.

I'm going to uninstall and try RC Phone instead.
Photo of Julie Sperritt

Julie Sperritt

  • 1,264 Points 1k badge 2x thumb
We have this issue with one user too.
We have logged a support ticket and were told it was a national issue.
Still waiting on a response from them, ticket was logged over a week ago.

We changed settings in app and on phone, it worked for a day then reverted back to adding the 1.
We deactivated the user and set them up again but still happened.

We have this issue for one user out of 250. 

An update/fix would be good!
Photo of Emily Graham

Emily Graham

  • 112 Points 100 badge 2x thumb
That's good to know, thanks.  The RC Phone app seems to work fine for me but I realise that's not a solution for users who need whatever else you get in the full RingCentral app.
Photo of Julie Sperritt

Julie Sperritt

  • 1,264 Points 1k badge 2x thumb
I think the RC phone app works well - but since it is being retired we have tried to stick with the RingCentral app. It's causing us a lot of pain though.....
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 12,890 Points 10k badge 2x thumb
A patch was released through version 20.1.12 to fix this issue. Can you please confirm if you have updated the app to the latest version?