Any idea on when the new Yealink W60P phones will be supported on RingCentral?

  • 0
  • 16
  • Idea
  • Updated 2 days ago
Photo of Iora


  • 334 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 16
Photo of Andre Sanchez

Andre Sanchez

  • 172 Points 100 badge 2x thumb
Definitely would like to know of a timeline. The handsets are identical to the W56P, but the base station is much more compact and overall better looking for placement in high visibility areas.
Photo of Mahesh Desai

Mahesh Desai

  • 60 Points
It's urgently needed. Hope RingCentral updates their system to support W60B and 56H. 
Photo of Noah Stahl

Noah Stahl

  • 102 Points 100 badge 2x thumb
Please support.
Photo of James Robinette

James Robinette

  • 110 Points 100 badge 2x thumb
Well I just bought what I thought was a 56H base station, but it was 60B.  No idea how to config it with RC.  There is no auto-provisioning feature in the 60B web interface that I can see.  If there's an easy solution to this, please advise.  If the 60B base station is plain not supported, please get it online, or I'm switching!
Photo of Jared

Jared, Alum

  • 976 Points 500 badge 2x thumb
Hi everyone,

At this time we only support and provision these phones for our RingCentral customers. I would suggest that you please vote for this feature request using the 'me too' option at the top of the page.
Photo of James Robinette

James Robinette

  • 110 Points 100 badge 2x thumb
Figured out how to manually provision, so now I don't care whether it's added or not.  For those of you in this thread who want to use the W60B with RC, it's pretty straightforward--search for the ringcentral instructions for the Yealink 52P, then adapt those instructions for the W60B.    Took me 5 minutes once I found it!
Photo of Robert Marks

Robert Marks

  • 120 Points 100 badge 2x thumb
I have made it work with only a mild bit of frustration - not sure to what degree it matters, though it does work.  I have a W60B plus two W56H phones attached to it.  I go to the IP address and login, then via Yealink Support downloaded the most up-to-date firmwares for both devices (W60B: and W56H:  Once updated, I login again to the IP address.  Then Settings --> Auto Provision.  I delete the username & password and add the URL provided for auto-provisioning from RingCentral.  The option to then Auto Provision is at the lower part of that page.  It worked, BUT the auto-provisioning annoyingly downgraded my firmware to one that was, I believe,  The phones than say "old firmware please upgrade" on the main screen, though the continue to work.  When I then upgrade the firmware, I have found that they subsequently automatically downgrade once again.  It appears that RC's Autoprovision is installing an antiquated firmware, which is annoying and frankly unacceptable.  They should update their software to either allow for us to manually upgrade the firmware or update their own custom firmware accordingly (assuming it's some sort of custom firmware).  Of note, while I have tested this out via my ethernet connection at home over the weekened, and it works with my office system without error (including incoming and outgoing audio), I cannot attest to long-term sustained usage since I just set these up over the weekend.  I'm definitely curious to know what everyone else is figuring out.  I hope this was helpful to you all!
Photo of Roman Chaban

Roman Chaban

  • 62 Points
Have same issue, do you have any updated resolution?


  • 76 Points 75 badge 2x thumb
Can you confirm these firmware versions? I could only find W60B: and W56H:  Did you use the auto-provisioning URL for the 52P or the 56P?  I've tried both URLs with the firmware versions specified above and have not had success.

Disregard.  There was an issue on RingCentral's side and I was able to provision the phones as well.
Photo of Pete Bucklin

Pete Bucklin

  • 64 Points
I'm having the same experience from my end as well.
Photo of Nicole Rehfuss

Nicole Rehfuss

  • 80 Points 75 badge 2x thumb
I had same issue and what I did was download the firmware for the W56b and updated the software to the base manually in Yealink. Once updated to lower firmware on phone, I was able to register and provision the phone to work. nothing else worked.


  • 76 Points 75 badge 2x thumb
What were the firmware versions you used?
Photo of Kirk Miesle

Kirk Miesle

  • 80 Points 75 badge 2x thumb
I'm going off of memory, but here's how I did it. Hopefully this helps someone...

#1. Perform the factory reset on the Yealink W60B base station. 

#2. Install the latest firmware on the base station (download:

#3. Under settings -> auto provision, enter the RingCentral provisioning URL for W56P (, clear out the username, password and key fields. Then click "provision now". This will allow the phones to be auto provisioned. 

#4. "Account 1" will be setup, if there are additional accounts mirror the settings and enter the username, authorization ID and password for each.

#5. Phones should work, however the handset firmware will be downgraded during the provisioning process and you'll see a message on the handset that you're running outdated firmware.

#6. Another issue is that the downgraded handset firmware will only allow 5 of the 8 handsets to be registered with the base.

#7. To fix these problems, upgrade the handset firmware of the first 5 registered handsets. 

#8. First go to settings -> auto provision and clear out the provisioning URL and save. This is important because the provisioning process will just downgrade the firmware after you upgrade.

9. Then go to settings -> upgrade and upgrade the handset to the latest version of the handset firmware (download: Once complete, if you need to register additional handsets (more than 5), delete a few upgraded ones that are currently registered to the base. Then, register the other handsets and perform a firmware upgrade again on those. 

10. Once all handsets are running the latest firmware you should be able to register all 8 handsets. Early versions of the W56H firmware only support 5 handsets.

11. When done, your base and handsets should be running the latest firmware and work correctly with RingCentral. 

12. Note - if you re-enter the provisioning profile URL, the handset firmware will be downgraded again. So it's important you don't do that after upgrading.

After going through this process, I've been running fine for the last few days. I'm unsure if any issues will crop up, but for now it works.

Photo of ADIM Matt


  • 180 Points 100 badge 2x thumb
Any update on this?  We were just notified by our vendor that the w56p has been discontinued.