How can I stop the smartphone mobile app from putting calls on hold when I'm already on a personal call?

  • 0
  • 6
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: iPhone puts RingCentral call on Hold when there's an incoming call to my phone

I'm using your APP on my Iphone 5S. The problem is that when I'm talking to a customer using your app, if I receive a call on my personal Iphone (where the app is installed), the app puts the customer on hold immediately. This happens weather I answer my personal call or not. How can this be prevented?
Photo of Mariela

Mariela

  • 144 Points 100 badge 2x thumb
  • frustrated

Posted 6 years ago

  • 0
  • 6
Photo of Desiree

Desiree, Alum

  • 7,270 Points 5k badge 2x thumb
Hi Mariela,

I see. Would you like to have the option to answer the call, or have the option to hold your personal call and then answer the RingCentral call? Or, both?

Thanks.

Desiree
Photo of Mariela

Mariela

  • 144 Points 100 badge 2x thumb
I would like to have both options.
Photo of Yanick Landry

Yanick Landry

  • 76 Points 75 badge 2x thumb
I would like both options as well.
Photo of John Ting

John Ting

  • 194 Points 100 badge 2x thumb
By that follow up question, it seems like there is no current solution. I asked this question today, without seeing this post earlier. I use a Samsung G3. So, it's an issue with Apple and Android.
Photo of michael

michael

  • 78 Points 75 badge 2x thumb
2 month point and no Answer yet?
Photo of Dennis

Dennis

  • 70 Points
Both options would be great, any update Ring Central?
Photo of Dennis

Dennis

  • 70 Points
Both options would be great, any update Ring Central?
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Hi all - this is an OS-level issue on both iOS and Android. Both platforms give "priority" to native calls - i.e., those that come in to the phone itself, rather than an app. The latest version of our Android app can be set as the native *dialer* on phones running Android 4.3 and above, but until either Google or Apple become more open with app permissions, we can't have incoming RC app calls take priority. A workaround is to have incoming calls forward to your cell phone number and not handle them over VoIP using the app. Sorry about this.
Photo of TINKER

TINKER

  • 206 Points 100 badge 2x thumb
since i have bbeen having the same problem on my softphone on more than one of my computers, what is the fix for that?
Photo of Ed

Ed

  • 90 Points 75 badge 2x thumb
Hi Ben -
Is this to say that the issue is fully resolved on Android 4.3 or later - that an RC app call would NOT be interrupted if a native call request were to come in?
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
No, the Android app update only applies to outbound calls. On Android and iOS both, incoming calls to the phone will still be given priority. 
Photo of Ed

Ed

  • 90 Points 75 badge 2x thumb
Thanks for the response, but this is unfortunate (at best!). Is there a solution in the works that would allow the RC call to be given priority? This is a large issue for most, I'd think.
Photo of Esther Thomas

Esther Thomas

  • 92 Points 75 badge 2x thumb
This and reporting are my two great frustrations. The way to make an outbound call on Ringcentral currently are to be on wi-fi and shut off your 3G. Then make your outbound Ringcentral call. Then turn your 3G back on. If you only have access to 3G service, forget it. All outbound Ringcentral calls will be interupted by any incoming iphone calls.
Photo of Ed

Ed

  • 90 Points 75 badge 2x thumb
I'm slightly confused on a method to shutoff cellular calling on an LTE (iPhone 5 device). Compelling idea for certain, though. Any tips?

Reporting, especially of missed calls, seems to be an issue on my side as well. Essentially, the missed calls list I see on the RingCentral.com user interface does not match up to what I see in the app. Is there a solution to this as well?
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
There's actually a setting within the app for the former - go to Settings > My Mobile App Settings > VoIP Calling and make sure "Over 3G/4G" is set to Off.

Regarding reporting, we are actually working on some major improvements to reporting and analytics. Look for these to debut later in 2014.
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
I understand the frustration. The limitation is due in part to the OSes themselves: On iOS, I don't believe it's possible to give app calls priority over native ones (a decision of Apple's). On Android, it may be doable (not sure and will have to check).

You can give RC calls priority by making them through your phone - either setting your personal phone number as a forwarding number (for incoming calls) or using RingOut instead of VoIP (for outgoing calls). It's VoIP calls, at present, that will be interrupted by native calls to the phone.
Photo of Ed

Ed

  • 90 Points 75 badge 2x thumb
Of course, the issue with the suggestion to use call forwarding or RingOut is that you end up burning your cell minutes all to avoid a call interruption by avoiding use of one of the app's native and core functions - to receive and place calls.
Photo of Michele Muldoon

Michele Muldoon

  • 70 Points
Hi, is there a solution to this yet?  How about with iPhone 6?  I am losing too many calls with this limitation.
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Michelle, there will be no solution to this as Apple will not allow any app to take precedence over calls coming directly to the phone.  the Android platform is not like that.  If a call comes in you will be able to ignore or answer.  The I phone is hard coded to not allow anything to get in the way.  I have spoken in detail to support about this.  So unleass Apple loosens up how the phone works this will always be an issue.

So a couple of things you could do. (I have some of these solutions in place for my customers)  Forward your Iphone number to ring central so that ALL calls to the phone are through RC and there will not be an issue.

Since your phone is used for business, port the Iphone number to Ring central.  this is more permanent but if a phone is for business it may be the right move.  Get a new number assigned to your Iphone and only give it out to a few people ETC.

I would start with the forwarding to see if that is better.

You could undo that if you don't like the way it is working

Hope this helps

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of Michele Muldoon

Michele Muldoon

  • 70 Points
Hi Chuck, thank you! Do you know of android has a work around? If so I will switch phones in a hot second.
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
I have tested with both platforms and the android will prompt you like call waiting does and give you the choice to answer the call or ignore and send to VM.
Do your own testing but that is what I was able to determine.  

Chuck
Photo of Nathan Lawrie

Nathan Lawrie

  • 80 Points 75 badge 2x thumb
For iOS devices, if you have WiFi available, you can put your phone on Airplane mode, turn on WiFi and make VOiP calls without fear of interruption.  Just don't forget to turn airplane mode off when you are done.  Not ideal, but its workable until a real solution is put in place.  
Photo of Dustin Youngquist

Dustin Youngquist

  • 60 Points
When you put your phone on airplane mode it disconnects the the WiFi too (at least on iOS 8), have you found a way around this?
Photo of Michael

Michael

  • 60 Points

I'm wondering if putting your iOS device in Do Not Disturb mode would work to prevent an incoming cell call from interrupting an existing VOIP call.  Has anyone tried this?

I don't have multiple lines to test it with, so I'm throwing it out there to see if anyone else can.


This conversation is no longer open for comments or replies.