Automatic call recording - Allow mute in auto call recording

  • 0
  • 2
  • Idea
  • Updated 3 months ago
  • Planned
  • (Edited)
Referring to RingCentral guidance this feature currently doesn't work. I can turn off call recording, but can't start the recording again.

We are required to record all calls, but are also required to not record card details. We need this feature to be fully functional. Auto call recording, turn on/off on demand.
Photo of Luther Yeates

Luther Yeates

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of Saadet

Saadet, Employee

  • 68,332 Points 50k badge 2x thumb
Hey Luther,

A colleague of mine and I did some testing on this. The On-Demand Recording function has to also be turned on, which is something that is not mentioned in the KB.

The second thing we found when working with the softphone (have not tested with a deskphone yet) is that you can stop the recording but you then cannot resume it, which I believe is not working as designed.

What happens for you once On-Demand is also turned on?
Photo of Kevin Sheehan

Kevin Sheehan

  • 66 Points
I have on-demand recording enabled and auto recording enabled. When doing tests for outbound recording, I have found similar results with the softphone. 

- When call is connected, message about automatic recording plays
- Pressing the record button on the softphone plays the message about call recording being stopped, however that button never changes to the Stop button. It just stays as a grey snipping circle.

I am using softphone version
Photo of Amy Price

Amy Price

  • 410 Points 250 badge 2x thumb
One set of instructions show this:  

While another shows this:  

Photo of Saadet

Saadet, Employee

  • 68,332 Points 50k badge 2x thumb
Official Response
Hey Everyone, if you're experiencing this, please open a case and include JIRA CNV-20904 in your notes!
Photo of Saadet

Saadet, Employee

  • 68,332 Points 50k badge 2x thumb
Hey Everyone, in our 11.0 release you will be able to Mute/Pause Automatic Call Recordings. The release is scheduled to roll out in February (barring any unforeseen issues).
Photo of Aaron Prince

Aaron Prince

  • 60 Points

We are still experiencing this issue  JIRA CNV-20904. The newest update is the 10.3.5    Is there a ETA on 11.0?
Photo of Saadet

Saadet, Employee

  • 68,332 Points 50k badge 2x thumb
Hey Aaron, unfortunately 11.0 for the desktop app was delayed due to some unforeseen issues/bugs. Keep an eye out for the update! Hopefully it will get pushed out in April but I'm not sure
Photo of Curtis Riggs

Curtis Riggs

  • 10 Points
Re: JIRA CNV-20904, is there a way that we can customize or eliminate the notification when pausing and restarting, we actually just want to mute the recording not stop and restart. 
Photo of Julian Diaz

Julian Diaz

  • 60 Points
I don't know if this is directly related, but I'm also unable to configure muting to work correctly.

We want both the ability to automatically record all calls and mute the call on demand.

When using the "RingCentral for Google" Chrome extension to place calls, this does not work.

Recording will start, but clicking the "Record" button plays a notification telling us that call recording is already enabled. We need to be able to turn it off for some calls. Pressing *9 has no effect, either.
Photo of Saadet

Saadet, Employee

  • 68,332 Points 50k badge 2x thumb
Hey Julian, the RC for Google Chrome app does not support this functionality right now.
Photo of AndyU


  • 62 Points
I have just tested the same scenario through the Ring Central desktop app (Glip) and have seen the same. If I try to pause recording I get a message to say recording is already enabled.