Bug - Call queue greeting - still play default greeting 'Please hold for the next available agent' at the end

  • 0
  • 5
  • Question
  • Updated 2 weeks ago
  • Answered
We have our custom greeting recorded to replace the default 'Thank you for calling <queue name>, please hold for the next available agent.'

In the queue's greeting section, everything is playing custom greetings in the preview, however, when doing an actual call (by calling our RC number), you will hear all the custom greetings, but at the very end, you'll hear the default 'please hold for the next available agent.'.

I had a chat session with Martin and he tested and called our RC number, tried to create a brand new call queue to replicate the original call queue but still hears the default greeting...  He mentioned, in the old interface, there is an option to uncheck the default greeting, but seemed it is no longer available in the new interface.
Photo of Eric Chou

Eric Chou

  • 180 Points 100 badge 2x thumb
  • very unhappy

Posted 6 months ago

  • 0
  • 5
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,426 Points 50k badge 2x thumb
Hey Eric, I'm going to do some research on this!
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,426 Points 50k badge 2x thumb
Hi Eric, thank you for bringing this to our attention. Our Product Team is looking into it and hoping to fix this issue in an upcoming release. When I learn more details about an ETA, I will update this thread!
Photo of Eric Chou

Eric Chou

  • 180 Points 100 badge 2x thumb
Any updates?  It's been two months and I have not heard any ETAs but frustration.  Thx.
Hi, just to add to the above, we have recorded custom greetings for all greetings we require but cannot find the option to remove or record custom greeting to replace "Please hold for the next available agent" which is played at the end immediately after our custom recording for the "this call is being recorded" message.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,426 Points 50k badge 2x thumb
Please open a Support Ticket and include JIRA: UI-3176 in your notes!
Thanks, have done so. The response I received was:


"We do not have any time frame when the issue will be fix. The system will send you a email notification once the issue is resolve."

Do you have any further information about when they are looking to fix this system bug?

Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,908 Points 20k badge 2x thumb
Barring any unforeseeable issues, the fix is scheduled for our 10.3 release. Fingers crossed nothing crazy happens that keeps it from getting done for that release! 
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
Hi there, so when is 10.3 release's ETA?  Thx.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,908 Points 20k badge 2x thumb
Hey Eric! We are going to start pushing out the update to accounts beginning early November :) You can ask your Account Manager when your account is scheduled to receive it.
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
Okay, will reach out to my Account manager.  Or is there a way to check see if the system is on 10.3 by chance?  Thanks.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,908 Points 20k badge 2x thumb
Hi Eric, there is no way for you to check - it's an internal view at this time.
Photo of Michael Berkeley

Michael Berkeley

  • 498 Points 250 badge 2x thumb
I have fixed this by setting the queue back to standard greeting, saving, then re-adding the custom queue greeting.
Photo of Eric Chou

Eric Chou

  • 180 Points 100 badge 2x thumb
mine is still not fixed/resolved after setting the queue back to standard greeting, save, and then re-adding the custom queue greeting.

Help...
Photo of Eric Greene

Eric Greene

  • 486 Points 250 badge 2x thumb
I also tried saving default greeting and change back to custom.  It worked on 3 call queues, but not all of them.  Definitely a bug with RC.
Photo of Chris A

Chris A

  • 60 Points
I also tried this, and it did not work.
But then I...

"UN-CHECKED" the "Call Queue Greeting" checkbox (disabled it)
Clicked Save
Re-Enabled (checked the Call Queue Greeting checkbox)
Clicked Save

Test called and, its gone!

Yes its a bug, its really quite silly that its not fixed because it seems like a "refreshing" issue that should be easy but.... This should work for you
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,426 Points 50k badge 2x thumb
Hey Everyone, just spoke with the Product Team and unfortunately there was a snag in getting this remedied. They also provided me with an updated JIRA number for new cases: UIA-70395

I'm keeping an eye on this one and will get a notification for when it gets fixed. I'll post here when I learn more
Photo of Eric Chou

Eric Chou

  • 180 Points 100 badge 2x thumb
Hi Saadet,

Thanks for the update.  Please let us know:
1. "When" this will be resolved - at this point in time, I demand clear visibility to the "date" when this UIA-70395 will be done and publicly available
2. The steps needed to get this corrected if needed (like to reset to default and re-customize again, etc...)

Please be reminded that I have filed this issue since 9/11/2018 and it's been 4 months and with the impression that will be fixed by December last year (3 months).

I would appreciate a faster turn around this time.

Thank you
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,426 Points 50k badge 2x thumb
Hey Eric, as I mentioned, I'm keeping an eye on this issue and will update the thread when an update is available. Unfortunately, I have no ability to create a faster turn around, since I am not part of the Product Team.
Photo of Chris McCaman

Chris McCaman

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled please hold for next available agent.



Please provide an option to disable the message “Please
hold for next available agent” when someone dials the call queue or group.
Photo of Eric Greene

Eric Greene

  • 486 Points 250 badge 2x thumb
This should be resolved by now and it is quite frustrating that Ring Central does not seem to think fixing their own bugs are important or maybe we're not important to them as clients?
Photo of Eric Greene

Eric Greene

  • 486 Points 250 badge 2x thumb
I also think they re-create new case numbers to rig their own SLA's.  Not cool. 
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 50,348 Points 50k badge 2x thumb
Hi Eric Greene, as someone who has personally been in a Support Role for RC, re-creating new cases does not affect SLA.

I understand that this current issue is quite frustrating! And, like I mentioned, I'm keeping an eye on the issue and once I get an update on a resolution, I'll post it here :)