Bug - Call queue greeting - still play default greeting 'Please hold for the next available agent' at the end

  • 0
  • 3
  • Question
  • Updated 3 weeks ago
  • Answered
We have our custom greeting recorded to replace the default 'Thank you for calling <queue name>, please hold for the next available agent.'

In the queue's greeting section, everything is playing custom greetings in the preview, however, when doing an actual call (by calling our RC number), you will hear all the custom greetings, but at the very end, you'll hear the default 'please hold for the next available agent.'.

I had a chat session with Martin and he tested and called our RC number, tried to create a brand new call queue to replicate the original call queue but still hears the default greeting...  He mentioned, in the old interface, there is an option to uncheck the default greeting, but seemed it is no longer available in the new interface.
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
  • very unhappy

Posted 3 months ago

  • 0
  • 3
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,276 Points 20k badge 2x thumb
Hey Eric, I'm going to do some research on this!
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,276 Points 20k badge 2x thumb
Hi Eric, thank you for bringing this to our attention. Our Product Team is looking into it and hoping to fix this issue in an upcoming release. When I learn more details about an ETA, I will update this thread!
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
Any updates?  It's been two months and I have not heard any ETAs but frustration.  Thx.
Hi, just to add to the above, we have recorded custom greetings for all greetings we require but cannot find the option to remove or record custom greeting to replace "Please hold for the next available agent" which is played at the end immediately after our custom recording for the "this call is being recorded" message.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 45,276 Points 20k badge 2x thumb
Please open a Support Ticket and include JIRA: UI-3176 in your notes!
Thanks, have done so. The response I received was:


"We do not have any time frame when the issue will be fix. The system will send you a email notification once the issue is resolve."

Do you have any further information about when they are looking to fix this system bug?

Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,704 Points 20k badge 2x thumb
Barring any unforeseeable issues, the fix is scheduled for our 10.3 release. Fingers crossed nothing crazy happens that keeps it from getting done for that release! 
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
Hi there, so when is 10.3 release's ETA?  Thx.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,704 Points 20k badge 2x thumb
Hey Eric! We are going to start pushing out the update to accounts beginning early November :) You can ask your Account Manager when your account is scheduled to receive it.
Photo of Eric Chou

Eric Chou

  • 140 Points 100 badge 2x thumb
Okay, will reach out to my Account manager.  Or is there a way to check see if the system is on 10.3 by chance?  Thanks.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,704 Points 20k badge 2x thumb
Hi Eric, there is no way for you to check - it's an internal view at this time.
Photo of Michael Berkeley

Michael Berkeley

  • 312 Points 250 badge 2x thumb
I have fixed this by setting the queue back to standard greeting, saving, then re-adding the custom queue greeting.