Call Handling: Incoming calls get my greeting first then the phone rings?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Incoming calls get my greeting first then the phone rings?

When someone calls, my away from my desk greeting begins. however then the phone rings. How do i correct this.
Photo of STEVE BALDASTI

STEVE BALDASTI

  • 70 Points

Posted 2 years ago

  • 0
  • 1
Photo of Jan Ferguson

Jan Ferguson

  • 136 Points 100 badge 2x thumb
Steve,

It sounds like you may have accidentally recorded your "Away" greeting in place of the Company Greeting, or possibly in your extension greeting (under Screening, Greeting & Hold Music).

This would cause your callers to hear an "Away" message/greeting but yet your phone would ring.

The final possibility would be some Advanced Calling rule which you might have set up and have set it to play your "Away" greeting.
Photo of Matt Mikolajczyk

Matt Mikolajczyk

  • 1,384 Points 1k badge 2x thumb
I see this is my company all the time. My users are setting the User Greeting item. The purpose of the User Greeting is to let people know they have reached the right number. The problem is that when people call it, they assume it is voicemail and generally hang up. This may be your case, Steve. Check to see if User Greeting is on. If it is, turn it off and test.
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 17,412 Points 10k badge 2x thumb
We have created a document that shows how to turn it off to prevent it from doing this because it is one of our most common helpdesk ticket items.  Folks assume it means their calls are routing straight to voicemail.    We have already asked RingCentral to get a UI change on this -  to either move that function or rename the User Greeting to something else or detail better explanation of what it is for on the exact area where it is set On or OFF - because users think that is where their Outgoing Voicemail Message is recorded.  Our document is here  https://drive.google.com/drive/folders/0B7B2Czx8N2aIWEVzLVpwcTNMb28?usp=sharing      Look for "Turn Off User Greeting"