Desktop App: add a "blocked" option in that caller ID list

  • 0
  • 11
  • Idea
  • Updated 2 years ago
  • Implemented
  • (Edited)
The new desktop app is a welcome refresh for the UI.

However I have noticed that the software does not allow you to call out blocked even that is a default set in the admin portal for that user on the website.

Tech support has no idea when this will be fixed.

I bet it has something to do with caller ID change option in the Desktop APP. It is overwriting the default settings from the website.

An easy fix would be to add a blocked option in that caller ID list.

I have had my users stay on the old version of the softphone for this specific reason, they make too many calls to have to press *67 each time, also they use the hotkey option which is a great tool but doesnt allow for pre-fixes to be added before the dial.

Now we are seeing things like notifications for faxes and voicemails failing to be sent to the old softphone, it is requiring a update to the latest version according to tech support. Looks like we are being forced into using the new software, which isnt bad, but atleast make sure all of the features work ! Every other phone system has caller ID blocking as a option.

Please fix this Ring central !

If you want this fixed , add a comment !

Drive this to the top!
Photo of Andrew Quist

Andrew Quist

  • 404 Points 250 badge 2x thumb
  • frusterated

Posted 3 years ago

  • 0
  • 11
Photo of Arshkit Dullat

Arshkit Dullat, Alum

  • 440 Points 250 badge 2x thumb
Official Response
Caller ID Blocking for outbound calls from the Desktop App is now available in the 8.0 version.