Calls dropped as they are being answered from voice prompt. Over and Over

  • 0
  • 1
  • Question
  • Updated 5 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate. If you have questions or comments related to this to thread, please create a new topic, or post to ano

When others are calling (most from a cell phone) the call drops when the voicemail prompt comes up. I press 1 to answer and it drops. This happens repeatedly while the person calling is still on hold. When I call support, they test it and it works perfectly. I need something that works in the real world. Am I the only one experiencing this? We may have to go to another service before our 30 days is up due to the calls constantly being dropped before we can answer them.
Photo of Christian Sarran

Christian Sarran

  • 70 Points

Posted 6 years ago

  • 0
  • 1
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Hi Christian, what do your call logs say? Are the entries the same compared to when RC support calls and you have no issues?

I have seen issues with cell phones and departments causing this issue.

I have reworked some call flow for my customers experiencing this issue.

Let us know

Thanks

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Hi Christian - if you're still experiencing this, please describe your call flows a bit so we can try to pinpoint the problem.
Photo of Patrick Robinson

Patrick Robinson

  • 60 Points
Looks like the thread has gone cold, but I thought I would post here before moving to a new thread.  I too have had this issue and it is definitely a big enough issue that we are contemplating looking for another provider as well.

Our set up operates as follows:  You call the 800# and immediately get a greeting that says, please press 1 for....please press 2 for....etc.  We have three total.  One is forwarded to a land line while the other 2 are forwarded to iPhones.

When a call comes in and a person presses "1", they are sent to me.  There are two scenarios...me answering, or not.  First, let's look at me not answering.  If I don't pick up, the iPhone will ring 3-4 times and then show I missed a call.  A few seconds later, it will do this again...then again...and perhaps a 4th time is the VM hasn't picked up yet.  (The super long wait time on VM is a whole other issue).  I don't understand why a call just keeps ringing me back time and again...doesn't make sense.

The second scenario is if I do pick up.  The phone rings and I answer.  Immediately I am given the cue call greeting...press 1 to accept, press 2 to decline.  At this point, it doesn't matter what I push...either way it hangs up...then it calls me again...I do the same thing, it hangs up....again and again....over and over....until that super long and super annoying, did I mention long wait time for VM to pick up occurs.  Then I have to hope that they left a VM or that I had their number come up on caller ID so that I can cold call them back on my personal number.  Either way, we are losing customers over this.

Anybody out there have any suggestions?
Photo of Sarah Vallieu

Sarah Vallieu

  • 60 Points
I too am having this issue.  Call logs show the call is on the line for 30-40 seconds usually (it has happened several times).  We are answering phones via VOIP or on iPhones forwarded from RingCentral (I hope that makes sense, we are brand new). It is taking a TON of time before we "hear" the ring on our side (three to six rings on customer--in-coming call) and when we hear the ring, and answer the prompt (press 1...) we are losing the call. 
Photo of Sean Smith

Sean Smith, Employee

  • 892 Points 500 badge 2x thumb
Hi all -
anyone who is experiencing this, please create a new support case at http://success.ringcentral.com/RCContactSupp.
Sorry for the inconvenience.


Photo of Brian Doelle

Brian Doelle

  • 60 Points
Hi Sean, we did open a new support case per your suggestion (#02795546), however only one of the two problems were addressed and the "fixes" have actually made the problem worse, not better. Any other suggestions on how to get our issues addressed quickly?
Photo of Sean Smith

Sean Smith, Employee

  • 892 Points 500 badge 2x thumb
Hello Brian.  Not good if your problem has gotten worse.  I checked on the case and it is being escalated.  Sorry for the inconvenience but working with our support is the best approach to identify root cause and correct.

This conversation is no longer open for comments or replies.