Can't install desktop version 9.1.2

  • 0
  • 2
  • Question
  • Updated 1 year ago
  • Answered
I get an error message when trying to install "There is a problem with this Windows Installer package.  A DLL required for this install to complete could not be run.  Contact your package vendor."    HELP!
Photo of Donald

Donald

  • 262 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 2
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 32,896 Points 20k badge 2x thumb
Hello Donald,

Could you post a screen shot of the error message you are receiving? Thank you!
Photo of Shesh

Shesh

  • 60 Points
I'm receiving this error message as well on multiple computers.
Photo of Mike

Mike, Official Rep

  • 89,760 Points 50k badge 2x thumb
There could be a couple things causing this.  This generally indicates a problem with the Windows Installer package, rather than the RingCentral software.  Here's a thread and Microsoft site you can refer to for more details. It might be as simple as running the microsoft tool or re-installing the Windows installer.

https://superuser.com/questions/478631/dll-could-not-be-run-for-msi-installers

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed...


If you can install older versions of RingCentral Desktop, but not this new version then there might be an incompatibility.   Try the above links and if you have problems, try rolling it back to an older version of RC Desktop and see if it installs correctly.

If you decide to roll it back, follow the steps on this page: 
Upgrade to the latest version of RingCentral for Desktop (Crash or Failed Installation after upgrading to 8.4.5)

Mike