Can't join meetings via URL with Safari as default browser

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Answered
If I try to open a meeting link or join via the Meetings site, and Safari is my default browser, it just downloads a new installer instead of joining the meeting. It works fine when I'm using Chrome. This seems to be related to the security issue that was patched in the last update. 

I tried clicking on the probable solutions link, but it gives invalid instructions:
  • "Allow Plug-ins" may have been an option in prior versions of Safari, but it no longer is.
  • I looked in Websites > Plug-ins, but there is no RingCentral Meetings plug-in. Should I have one?

Photo of Dave Graham

Dave Graham

  • 132 Points 100 badge 2x thumb
  • frustrated

Posted 4 months ago

  • 0
  • 1
Photo of Paul Pecullan

Paul Pecullan

  • 538 Points 500 badge 2x thumb
While it is very likely related the security issue recently patched RingCentral has dropped the ball on and would rather tell us to use a different browser than actually offer a real fix.  As I'm sure you know RingCentral meetings is rebranded Zoom.  The patched Zoom works just fine so why can't RingCentral Meetings.


Photo of Saadet

Saadet, Employee

  • 67,992 Points 50k badge 2x thumb
Official Response
Hey all,

We are aware of this issue and working to get it fixed. It does only happen is Safari is listed as your default browser. So until we push the fix out, which should hit the first week of August, you'll have to change your default browser or simply grab the Meeting ID and paste it directly into the RC Meetings app.
Photo of Dave Graham

Dave Graham

  • 132 Points 100 badge 2x thumb
Thanks Saadet. I'm doing it manually for now, but it's harder to guide non-technical folks I'm meeting with. 

I really question the decision to locate the RingCentral Meetings app in ~/Library/Application Support/RingCentral Meetings/. The installer does place a shortcut on the desktop, but it's easy to miss since some folks have thousands of items on their desktop. Because it's in a non-standard location, you can't open it via Spotlight or by going to the Applications folder, which is where it should be to begin with.

BTW... I can't even log in to the RC Community with Safari. Having to use Chrome to post this reply. 

Dave
Photo of Saadet

Saadet, Employee

  • 67,992 Points 50k badge 2x thumb
Hmmm....that's weird that Safari is acting weird with Community. It's a completely different platform than RingCentral.
Photo of Paul Pecullan

Paul Pecullan

  • 538 Points 500 badge 2x thumb
Same issue here.  For me the problem was this: 
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 8,586 Points 5k badge 2x thumb
Hey Paul, 

This happens a lot if you have ad blockers on, might be worth checking it out :) 
Hi Dave,
1. Are you still seeing the Safari issue? 
2. Regarding the location of the RC Meetings app, does the user have admin privileges on the computer in question? If the user does not have admin privileges, then the Applications folder does not work for updates, etc. 
Photo of Dave Graham

Dave Graham

  • 132 Points 100 badge 2x thumb
Samudra, 

It's working great now. Thank you!

There are two options when installing apps on macOS: 1) install for all users on the computer, or 2) installing for the current user only. Many installers present both options and let the user decide.

Installing for all users on a computer requires admin privileges and should install in the Applications folder. This should be an option for enterprises that deploy and manage apps for their employees, or for local users who do have an admin account.

A common practice for installing apps for only the current user is to install in ~/Applications/, which does not require admin privileges. Here's a screenshot of my user's home folder. The Applications folder is not present by default, but if it's there, macOS identifies it as an apps folder (see icon in screenshot below). This is preferred over burying it in ~/Library/Application Support, which is inside a hidden folder. Your current practice places an alias on the user's Desktop, which is required since the app is in a hidden folder, however installers should never place things on the Desktop without asking the user.