Chrome browser, "Web Phone Unavailable", "Please grant RC permission to access audio" No option to grant appears?

  • 2
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Starting recently with the new RingCentral Chrome app, when I try to use the application for the first time on a new system I haven't used before, it's supposed to have a popup asking me to "allow microphone/audio" for this webpage.

This isn't happening sometimes and the Chrome softphone won't initiate Chrome to ask the question. The Chrome browser no longer has the option to set this manually in settings either.

Things I have tested this on, Windows 10 and Chrome OS (version 65). The same problem happens on both types of computers.

Using the hamburger menu on the RingCentral app and choosing settings to pick a different "Calling" option and then switching it back to "Browser", no effect. Going to the Audio tab it says, "The app does not have permission to use microphone" with the option to "Check Permission", this also has no effect and won't trigger the popup, only the following message,

On whatever web page I have open with the RingCentral Chrome app running, if I click the web pages "i" or "Secure" box, it doesn't have any settings to modify either.

Ideally, I wish there was a way to set this organization wide through G Suite, but I don't see an option for that either. Maybe someone could drop a hint at Google at how useful this feature would be as well.

I've tried logging out and back in, still no luck. Any suggestions/ideas?

This all started with the recent changes to your Chrome app.
Photo of ELLIS


  • 142 Points 100 badge 2x thumb

Posted 2 years ago

  • 2
  • 1
Photo of Luke

Luke, Training Specialist

  • 3,868 Points 3k badge 2x thumb

Due to the upgrades we've made in the RingCentral for Google plugin, it is required to ask for your permission to use your computer's microphone again.
Most of the time it should simply ask the first time you open it after installing/updating, see image below.

If it does not prompt you to approve access to the microphone, you should be able to click the red banner that says "Web Phone Unavailable", and approve microphone access in the same type of popup.

If neither of those options work, you will have to go through the Chrome settings. You can see your microphone settings by navigating to chrome://settings/content/microphone?search=microphone in Chrome. If you see RingCentral for Google in the "Block" list, you will have to remove it by clicking the trash can icon to the right, then quit and reopen Google Chrome and the RingCentral for Google extension. When the extension opens you should be prompted for access to the microphone again, or you may have to click the red error message again.

There's more information on Google Chrome's microphone settings and troubleshooting tips at their Use your camera & microphone page. Let us know if following these steps helps you out!