Chrome Extension Click-to-dial Popup

  • 0
  • 2
  • Idea
  • Updated 1 month ago
Does anyone know how to prevent the Chrome extension from taking over as the active window and popping up in front of the current browser page when a user clicks-to-dial?  Currently we have the extension configured to use the polycom vvx phones and the ringout feature as the call path.  The user doesn't need the chrome dialer interface.  All we really need is a clean, functional click-to-dial experience using the physical handset as the audio path.  Associates do not want to have to minimize the interface with every click to dial, especially when they are making 100+ calls per day. 

*Additionally, none of the desktop applications or softphone applications seem to have the proper capacity to control the physical handsets which is a typical feature of an enterprise-grade UC/Telephony system.  The user should be able to click buttons, for example, hang-up/end call in the desktop applications with the result being that an active call on the physical handset ends and the handset goes back on hook.
Photo of Brad Chason

Brad Chason

  • 80 Points 75 badge 2x thumb

Posted 1 month ago

  • 0
  • 2
Photo of Jessica - Community Support

Jessica - Community Support, Official Rep

  • 1,246 Points 1k badge 2x thumb
Hi Brad, 

I'm following up with our Integrations Team to confirm this for you. I'll let you know when I have more information! 
Photo of Jessica - Community Support

Jessica - Community Support, Official Rep

  • 1,246 Points 1k badge 2x thumb
Hi Brad, 

At this time, there isn't a way to completely disable all popups from the app-- I flipped this to a feature request for this functionality! 

As a workaround, you are able to go into the extension options from chrome://extensions => find RingCentral extension details => extension options, then choose to show RingCentral on all websites except the blacklisted (2nd option), then add a '*' blacklist entry. This will effectively blacklist every website. When you use click to dial features, only a standalone page will popup. 

The setting page should look like this: