Cisco SPA504G: can't get IP address at work but can at home...

  • 0
  • 1
  • Question
  • Updated 5 years ago
  • Doesn't Need an Answer
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution has become inactive, or information contained in this thread is no longer accurate. If you have a related question on this subject, please post a new topic.

I'm new to RC and setting up service both at home and my own small business.

I'm having issues at work setting up the 504G phones. I've tried setting up 2 phones at work and both now remain on "Initializing Network". (When I go to Setup > 9 Network, I see so I know that they are not getting local IP addresses issued.) Interestingly, at work, I did successfully set up 1 504G phone but when I tried setting up the 2nd 504G phone, the 1st stopped working. 

At home, I set up 1 504G phone and it works fine. 

At home AND at work, I'm using Comcast for Internet. The only difference as far as I can tell is this:

at home, I use a Comcast-issued cable modem: TECHNICOLOR tc8305c
at work, I also use a Comcast-issued cable modem: Netgear CG3000DCR

Any ideas on how I should go about troubleshooting?
I've read a bit and heard I should just buy my own modem for work - something like the Cisco DPC3008, or I could pay for a static IP address ($19.95 per month). Buying my own modem would be cheaper in the long run. 

Photo of SLin


  • 70 Points

Posted 5 years ago

  • 0
  • 1
Photo of Mike

Mike, Official Rep

  • 94,248 Points 50k badge 2x thumb
Hi SLin

There could be a few different things going on. It's possible that you may need to get a different router, but first here are a few things do double check. 

Resolving Initializing network error message

Setting Up Port Forwarding on a Netgear Router

Also, here is a list of the recommended routers. 


This conversation is no longer open for comments or replies.