Cisco SPA525G Randomly Changing Its Time

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • In Progress
  • (Edited)
We just provisioned 12 Cisco SPA525G phones yesterday to our new RingCentral account.  Every one of the phones is randomly changing the display time and restarting throughout the day.  Any recommendations on how to fix both these issues?

The phones were all purchased new from Amazon and have never been used or implemented prior to yesterday.
Photo of Kelsey Charron

Kelsey Charron

  • 120 Points 100 badge 2x thumb

Posted 4 months ago

  • 0
  • 1
Photo of Chris Duquette

Chris Duquette, Champion

  • 14,524 Points 10k badge 2x thumb
once you have the phone provisioned correctly make sure you call ringcentral support and have them "lock" the phone. I had a red triangle pop up on all 18 of my last polycom phones and had to have support help me out so that the date and time would stay on the phone and i would not see the triangle. maybe you are having a simliar issue but with a cisco phone? couldnt hurt to ask support
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Hi Kelsey!

Are you still having issues? Or did Chris's suggestion help? :)
Photo of Kelsey Charron

Kelsey Charron

  • 120 Points 100 badge 2x thumb
The phones are holding the time now, after I programmed them individually through their IP and through RingCentral.  They are still restarting multiple times each day though.  At least twice a week one of the phone will have all its lines light up red and it will stay that way until we manually reboot the phone.  I updated all phones to the current firmware about two weeks ago and the issue still persists. 
(Edited)
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Hmmm.....when the phone's have this issue, have you noticed if your internet is down?
(Edited)