Desktop App: Messages & HUD are not refreshing

  • 0
  • 8
  • Question
  • Updated 11 months ago
  • Acknowledged
  • (Edited)
I am having issues with software not refreshing. 

  • Message notificationstake ages to arrive if at all 
  • HUD claims that either other phones are available,but they are not or they are active and they are not.  
I do not believe it’s a firewall issue or anissue with my router. I have turned SIP ALG off on my router which made nodifference. We have 6 seats on Windows 10 and 7 and both behave the same. I havecalled the help desk to be only advises to uninstall and reinstall.   
Photo of Adam Robinson

Adam Robinson

  • 170 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 8
Photo of Kim

Kim, Alum

  • 43,524 Points 20k badge 2x thumb
The new versions of the softphone use a new set of IP subnets to signal presence for the HUD. In order for the HUD to work correctly you need to make sure that your router or firewall will allow traffic both inbound and outbound from the below noted IP addresses over the ports listed on our network requirements page.

This list of ranges is specifically for the Desktop App:
    Check for Network Requirement updates here: Network requirements

54.249.82.128/26 
54.236.3.128/26 
54.241.191.192/26 
54.246.196.128/26 
54.207.127.192/27 
37.58.79.160/27 
198.11.216.98/27 
5.153.35.160/27 
50.22.5.112/28 
54.175.63.64/26 
54.93.127.192/26 
54.209.255.64/26 
54.241.191.64/26 
54.219.189.192/26 
52.4.63.128/26 
54.233.127.192/27 
54.219.189.64/26 
54.175.191.192/26 
54.250.252.0/26 
54.171.191.192/26 
54.93.254.192/26

Other things to try: 
  1. (MAC) Clear Softphone library data to isolate any software issues with message threads loading properly.
  2. (MAC/PC) Ensure that proper ports are setup on local network; For example, ports 8000-8200 are utilized for softphone functionality.
  3. (MAC) Make sure that OS X’s integrated firewall is not blocking RingCentral for Mac, and allowing full access (System preferences/Security/Firewall). 
Note: Windows 10 is still in beta at this time

I hope this helps.
(Edited)
Photo of Barry Elk

Barry Elk, Champion

  • 980 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Desktop App for Mac - slow to display messages.

OS X - 10.11.1
RingCentral for Mac
Release: 7.4.1.17562 (64-bit)

Mac users are experiencing two types of delays related to RC Desktop for Mac.

First - severe lag between desktop and mobile message delivery.  Quite often can read message on mobile RC app before desktop app will even display notification of new message.

Second - lag or sometime no display of message thread.  Clicking on a message thread (whether there is a new message or not) will display a blank screen with no message history.  Closing that thread and re-opening will usually restore.

Third - hitting SEND from from desktop app will often show a 5-10second delay with the green progress bar and the word SENDING at the top.

Is this a client or server-side problem?
I also am having issues with the desktop app not refreshing.  Today is February 13, 2018 and the last message showing was February 9, 2018.  I had to go to my mobile app to even retrieve my faxes.  The app does refresh if I remove the program and reinstall but what a hassle.
Photo of Adam Robinson

Adam Robinson

  • 170 Points 100 badge 2x thumb

You will find that it still will not refresh even after a reload, waste of time. It will also certainly be your router not compatible with RingCentral, I know mad for the number 1 software. I had a Draytec router which is not that uncommon to finally be told it will not work finally after many painful calls to Manila. I change ISP to Virgin, used their hub and it works 100%

Very poor, wish I would have signed up to a different VOIP provider now.  

Photo of Bob Robinson

Bob Robinson, Champion

  • 2,852 Points 2k badge 2x thumb
We intermittently get this problem.  Our network settings are up-to-date but we still have users that receive an e-mail notification that they got a text, only the desktop app shows nothing.  They have to scroll to the bottom of the list of text messages to click the three dots (show more) and then the new text will appear, but the same happens again for future texts.  Similar issue for faxes.

I'm sure I'll be told to go to the idea center for a product suggestion, but could they at least move the refresh option (show more) to the top of the RingCentral Desktop app window?
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 54,126 Points 50k badge 2x thumb
Official Response
Hello Everyone, 

If you are having these issue, please open a case so we can get the debug logs from the softphone and investigate what's going on.
  
Photo of Merillat

Merillat

  • 142 Points 100 badge 2x thumb
Same issue.  Started a month or so ago. Intermittent.  Sent the Debug files along with screen shots etc.  Get the standard reply to verify router settings, etc.  Have looked at the debug files and clearly see that the api calls to pubnub are coming through so it's not a router issue (Cisco ASA 5512). Works perfectly for x amount of time, then fails.  Guessing server side issue.
Photo of Ryan Wessel

Ryan Wessel

  • 842 Points 500 badge 2x thumb
Mac Client Ver. 9.4.3 I have the same issue -- call history fails to update and texts will come 10 seconds after I get them on my mobile device.  This happens at both my office and home.  My computer is in the DMZ on my router and the Mac firewall is shut off.  So I know it's not a firewall issue.  What do you expect.. we just got picture text messages ... I feel like Ring Central tech side is old and antiquated.... like a bank for 486's with power stackers ...lol
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 54,126 Points 50k badge 2x thumb
Hi Ryan, the new 10.0 version is being rolled out right now (I believe it finishes at the end of this month or sooner). Once you have received the update, please let us know if you're still having issues!
Photo of CJ Patracone

CJ Patracone

  • 800 Points 500 badge 2x thumb
I have the issue where it is always a day behind, will they be improving this app anytime soon? I really just use it like a old phone that has no features. I have run into all sorts of issues since the implementation of ring central.
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 18,750 Points 10k badge 2x thumb
USA-based acct | 2287 Users | 3800 DID lines | 28 sites | all Polycom VVX500 phone handsets 

2018-05-18  You can download the updated version of the RingCentral for Windows HUD (now renamed RingCentralPhone) here  and it did resolve the same issue for us.....

https://success.ringcentral.com/RCSupportPortalDownloads
Photo of CJ Patracone

CJ Patracone

  • 800 Points 500 badge 2x thumb
I was specifically told by my IT not to download the new update as it is breaking many things here at our office, has this been released in the last few days?
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 18,750 Points 10k badge 2x thumb
No I think it came out last month around April 15 or so...     We have been using the new version without problems and we have 2287 users  - as I said, it did resolve the message indicator back to current real time display instead of lagging.      If you choose not to update to the current version, the workaround is unfortunately to Log out of the app and re-login   this clears its message cache and displays the correct info.  Not a great solution, but what will work if you do not do the version update.    Check your version# using the Gear Icon and then , are you still on  version 9.43?
(Edited)
Photo of CJ Patracone

CJ Patracone

  • 800 Points 500 badge 2x thumb
That explains the day behind since i login every morning, I am currently on 10.0.0
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 18,750 Points 10k badge 2x thumb
It may have something to do with it, but it could be other things on your network as well. I would  suggest that you open a RingCentral support case and ask them to review your configuration to rule out other possibilities.    Also


Saadet posted this earlier in this same thread above a few months ago ----

 Saadet - Community Support, Official Rep

  • 28,820 Points 20k badge 2x thumb

Official Response

Hello Everyone, 

If you are having these issue, please open a case so we can get the debug logs from the softphone and investigate what's going on.
  

Like  Comment
(Edited)