Disable Mobile App Integrated Calling on demand

  • 0
  • 2
  • Question
  • Updated 10 months ago
  • Answered
There are times when I do not want my business phone to ring thru to my iPhone.  I do love the Integrated Calling feature, but it would be much easier if the feature only ran or worked when the RingCentral app is running in the background.  I would like the ability to close and/or shutdown the RingCentral app so that calls will not ring thru to my iPhone.  For example, when I am in the office, I do not need my iPhone ringing too (this runs down my battery).  Then, when I get up form my desk, I simply run turn on the RingCentral app in the background to allow calls to ring thru to my iPhone.

Based on what I am seeing, the only workaround to keep calls from ringing thru to my iPhone is to 1) Disable Integrated Calling on the app and 2) Close the App.  That is two steps that you have to undo to turn integrated calling back on.

My recommendation is to 1) either allow the phone calls to stop when the app is not running in the background or 2) offer some sort of Status update so it shows (maybe Orange) on the iPhone to indicate that Calls will not interrupt you on your mobile device.  Then when you are ready to receive calls back on your iPhone, you simply 1) launch the app or 2) change your status on your app.  Currently, changing your status effects your Desktop app and prevents calls from ringing thru to that device too.  

The simplest process would be to allow you to close the app in the background if you don't want to be bothered by VOIP calls and re-open the app when you are ready to resume taking calls.  That is how the app should ideally work.  
Photo of Wade Whiteside

Wade Whiteside

  • 168 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of Cecile Glassy

Cecile Glassy

  • 14,170 Points 10k badge 2x thumb
Another option in wide use in our organization, is just to set the caller hours via the CALL HANDLING option in the portal.  You can easily create a daily schedule, for example to accept calls only between 8am and 5pm Mon - Fri  or whatever suits your scheduling needs. Can be set very granularly.
Photo of Wade Whiteside

Wade Whiteside

  • 168 Points 100 badge 2x thumb
Cecile, that is a great idea, however, I am in and out of the office a lot and it is hard to predict my schedule. For this reason, I would like the ability to easily disable calls to my cell phone while I am at my desk and have regular access to my desk phone. Thanks for your feedback. If anyone has figured out a solution, please let me know. If not, please vote for this idea so that a solution can be built.
Photo of Cecile Glassy

Cecile Glassy

  • 14,170 Points 10k badge 2x thumb
In the Call Routing area of your Portal settings, there is an On-Off button for each device just login and turn off the routing to your mobile when you want it to only ring your desk phone. Then turn back on when your cell should receive calls away from your desk....
Photo of MARION

MARION

  • 234 Points 100 badge 2x thumb
Cecile, I am having trouble locating this in the portal settings.  I am just learning so please bear with me.  How do I get to this setting ?
Photo of Wade Whiteside

Wade Whiteside

  • 168 Points 100 badge 2x thumb
There is not a device named mobile app. The only setting is to disable the Desktop apps & Smartphones, which in my opinion should be separated as they are two different devices. If I disable this, I agree, it will disable the mobile app, but it will also disable my desktop app which I don't want to do while I am st my desk. RingCentral needs to figure out how to have the mobile device disabled or enabled onnits own without impacting other devices.
Photo of Mike

Mike, Official Rep

  • 89,840 Points 50k badge 2x thumb
If you want the Desktop app to ring, but not the mobile app, simply go to the Profile page on the Mobile App and turn off the "VoIP Calling" switch as shown here. 

Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
You're welcome! :)
Photo of MARION

MARION

  • 234 Points 100 badge 2x thumb
Ok, I did that and it has quit.  Thank you.  
Somehow my extension on the Polycom phone is not ringing.  Do you know how I get that back?  
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
Hello MARION,

I took a look at your account and it's probably because your DND is set to Do Not Accept Call Queue Calls  

The orange circle is located online in the right-hand corner near your name and the logout button. See if that works :)
Photo of MARION

MARION

  • 234 Points 100 badge 2x thumb
That worked !!  Thank you so much! :)
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
Of course! :)
Photo of Wade Whiteside

Wade Whiteside

  • 168 Points 100 badge 2x thumb
All, with the solution that Mike provided above, I have found the solution to my problem.  
(Edited)