Don't Interrupt Typing When There is an Incoming Call

  • 1
  • 9
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
On the soft phone we have our 7 users setup to simultaneously receive calls. So all seven users see the incoming call if nobody is on the phone. Every user has complained about how annoying it is when they are in the middle of typing an email or inputting information into a form and the incoming call interrupts the typing. I think the softphone should pop up and notify but just be on the background and not override a user in the middle of typing.

You sometimes have to move the mouse back over to the box where you were typing to resume. Especially for our growing business that gets a ton of inbound calls, this can be quite bothersome. 
Photo of Andrew Uhacz

Andrew Uhacz

  • 214 Points 100 badge 2x thumb
  • upset

Posted 3 years ago

  • 1
  • 9
Photo of Benito

Benito

  • 516 Points 500 badge 2x thumb
100% agree that this needs to be fixed, I mean it's great that the incoming call pops up, but not at the expense of disrupting the workflow. Our users need to enter notes about the previous call in our system.
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 21,860 Points 20k badge 2x thumb
Yes  this is a really strong NEED!
Photo of Andrew

Andrew, Champion

  • 2,696 Points 2k badge 2x thumb
I agree that this should be an option to disable in settings.  
Photo of Chris Duquette

Chris Duquette, Champion

  • 16,778 Points 10k badge 2x thumb
is there not a way to make it ring and run in background and not come to for front when a call comes in? i havent used a softphone much so im a little new to that application.
Photo of Saadet

Saadet, Employee

  • 68,092 Points 50k badge 2x thumb
Official Response
Hello Everyone,

You can deactivate this occurrence within the Softphone settings as pictured below:

Photo of Shelly Roth

Shelly Roth, Champion

  • 1,964 Points 1k badge 2x thumb
Unfortunately, this did not help for us.  We still need the option to be able to answer the incoming phone call, just don't want it to interrupt our typing when a call comes in. If you deactivate the pop up for the incoming call in the standalone window, there is no notification of the incoming call at all.  Not helpful.
Photo of Andrew Uhacz

Andrew Uhacz

  • 214 Points 100 badge 2x thumb
I think this will work for some users. I just like the popup and wish it did the same thing. I just tested while typing and it didn't interrupt so this might work for some people. Thanks