Echo on RC Phone, but not Glip, same settings, same device.

  • 0
  • 2
  • Question
  • Updated 2 months ago
  • Acknowledged
Testing out some devices for office users. No matter what hardware setup I use, the remote person always hears themselves when I use RC Phone. When I use RC App, the remote person will not hear themselves. I tested this in my office, and from home. Same result. 

I have already made several changes to the hardware volume settings on the mic levels as troubleshooting steps. It's just weird that the RC App works perfect and RC Phone doesn't.
 
This would seriously be a non-issue for us IF the RC App could pull contacts from Exchange or Outlook, but that's another can of worms. 
Photo of Justin Jorgensen

Justin Jorgensen

  • 246 Points 100 badge 2x thumb
  • frustrated

Posted 9 months ago

  • 0
  • 2
Photo of Justin Jorgensen

Justin Jorgensen

  • 246 Points 100 badge 2x thumb
Just tried using Google Voice with the same hardware, same settings. No issues. What is the deal?
Photo of Justin Jorgensen

Justin Jorgensen

  • 246 Points 100 badge 2x thumb
Had to unselect and reselect. Then it started to perform like the other apps.

Photo of Jeff Salisbury

Jeff Salisbury, Champion

  • 2,132 Points 2k badge 2x thumb
We have observed echo when a Windows user used the RC Desktop app which does not occur if you are using the Mac RC Desktop app. This only occurred if you were trying to use the built-in microphone and speaker - if you used a headset this was not an issue. RC had documented the issue but no fix has been deployed as of yet.
Photo of Justin Jorgensen

Justin Jorgensen

  • 246 Points 100 badge 2x thumb
The issue has resurfaced. Called support again. We uninstalled the application and reinstalled. This worked for a short time and then reverted back to remote side echo. 
Photo of Saadet

Saadet, Employee

  • 67,790 Points 50k badge 2x thumb
Hmmm...the 11.0 version should be releasing in a few weeks. I wonder if that would be better? You can call Support and ask for the 11.0 version in order to test and confirm! :)
Photo of Rickkee

Rickkee

  • 590 Points 500 badge 2x thumb
I fussed for days with intermittent echo on RCPhone and Jabra GN8110USB, (didn-t try Glyp)    The solution to my problem turned out to be adjusting the speaker volume in windows.  Control Panel / Sound / Playback /GN8110 device / Levels.  Currently set to 7 with no echos.  I can adjust the RC control some, and my headset so I can hear the caller well.  This device has worked flawlessly until about the last two months, where it had been totally unreliable and only worked intermittently.
Hope this helps someone else out.  I am guessing it is caused by Windows 10 1903 update  currently running V1903.18362.356.  Good luck, it drove me batty for a few hours, but holding steady now.  Note that adjusting the microphone volume and RC auto-adjust on and off made no difference...It was a speaker volume issue that must be conduction related?


(Edited)