Feedback from a new (happy) customer after first month

  • 1
  • Praise
  • Updated 5 months ago
I found these forums helpful while configuring my new RingCentral system, so I thought I should leave some of my own feedback for other potential customers.

First, I was switching from another VoIP vendor so I was familiar with all of the basic concepts, softphones, smartphone apps, etc. Also, my main phone number was a Google Voice number that would be ported to RingCentral if I was satisfied after a few weeks of testing.

Provisioning a new RingCentral account, including configuring some existing Polycom phones from my previous vendor was easy and quick. Phone calls worked perfectly from day one and the call quality has been very good.

The only problem I had during my initial few weeks was SMS (text messaging) - I could send messages, but not receive. It took a full week and many exchanges with tech support people before they got their "telco people" involved and resolved the issue.

With all of the problems worked out and satisfied with the quality I started the process of porting my Google Voice number. I was nervous about this because all of my business clients use that number, but RingCentral handled the change perfectly. They sent emails to let me know what was happening and when, and the porting was completed on the expected date.

However, after my Google Voice number was successfully working at RingCentral for voice calls, I again experienced a full week of problems related to text messages. One problem was that I couldn't send text messages from the softphone app on my Mac. Every attempt to send a text caused a dialog box to pop up saying that my account was not authorized for SMS. While that was happening I had no trouble sending messages from the iPhone app, and those messages would all appear on the Mac softphone so my account was clearly "authorized" but the softphone just wasn't working.

The other SMS problem is that my ported number could not be used as the "caller ID" for text messages. This was particularly annoying because nobody recognized the new RingCentral-assigned phone number that did appear. Many, many messages went back and forth with tech support before it finally got "escalated to the telco group" who were able to fix the problem quickly.

Nobody would ever tell me exactly why I had two separate weeks of SMS problems, but I have a guess: a) it just takes longer to make SMS work because routing of text is completely different than voice; b) the new customer onboarding team is more focused on voice and they don't follow up to make sure all of the components are working properly; c) smartphone and softphone apps are buggy and need work. Regardless of what the problem is, I suggest RingCentral should do two things: 1) escalate problems to the "telco people" faster when SMS isn't working properly; and, 2) be honest about the timeframe to make SMS work on new accounts if there is really a structural delay built into that provisioning process.

So, now I am almost 5 weeks into my relationship with RingCentral and I am generally happy with everything. There are a few minor issues that I am still trying to resolve with the tech support folks, but overall it's a great service for a reasonable price.
Photo of Robert Stoeber

Robert Stoeber

  • 1,668 Points 1k badge 2x thumb
  • happy

Posted 4 years ago

  • 1
Photo of Carrie Ann Kroft

Carrie Ann Kroft

  • 188 Points 100 badge 2x thumb
Hi Robert, 
I know this post was from a while ago but can you tell me what the resolution was for not receiving the SMS messages.  We have been having a terrible time since 1st logging a ticket on January 3rd.  Still no answers.  Our reps are not receiving the texts at all or they are delayed/they have to log off/on or refresh to get them.  It seems no Tech at RC knows why, users are frustrated to say the least, they no longer want to use this system.  Everyone is now on 9.4.3 which didn't fix it.  Any thoughts or anything that you can remember would be great.
Thank you!
Carrie Ann
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 28,882 Points 20k badge 2x thumb
Hi Carrie Ann,

Sorry for the issues! Looks like this was supposed to be fixed in the 9.4 release. Since you're still having issues, we will need for you to open a case so we can investigate.
Photo of Carrie Ann Kroft

Carrie Ann Kroft

  • 188 Points 100 badge 2x thumb
Saadet - Thank you for this information!  We have been asking if 9.4.3 fixes this and no one could tell us, is there a doc or a link where I can see the details of what was fixed in 9.4, Sorry also did RC know this was an issue, which is why the fix is in 9.4?  We opened a ticket on January 3rd, and there really has been no movement on it.  We slowly rolled out 9.4 bc we had so many issues with 9.3.5.  Our users have lost confidence/faith in this system, many are using their own cell phone now for texting, we are trying to trouble shoot what is coming in from them.  We have over 100+ on the system we get around 30 emails daily on this issue.  I would love any and all details you can give me as orders have been missed and this has now caught the attention of our directors to which we now have a conference call on Monday with them.  I would love to be able to say with confidence, yes, upgrading to 9.4.3 will fix this texting issue.  If you any any details of the fixes in 9.4.3 you can provide that would be much appreciated.  I could also give you my cell number is you wanted to chat or my e-mail address.  Thank you, Carrie Ann
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 28,882 Points 20k badge 2x thumb
Hi Carrie Ann,

Sorry, there's no customer facing link with that type of information - it's all internal. However, according to the JIRA ticket for this issue, it was fixed in the 9.4 release. But it sounds like not everyone is on the 9.4 release? 

If everyone is on 9.4.3 and still having issues, then we will need a new case opened with fresh samples so we can see if there's something else/new that is causing this issue for you. The support agents you work with will have more information on the matter than myself.
  
Photo of Carrie Ann Kroft

Carrie Ann Kroft

  • 188 Points 100 badge 2x thumb
Thank you Saadet, we have opened a case we are running a debugger, yes are users are on 9.4.3 and it's still happening.  Would it be possible for you to give me the JIRA ticket number so I can let our team from RingCentral know what that is so that they can look it up.  We have asked what bugs were fixed in 9.4.3 but can't seem to get an answer.  Thank you!  Carrie Ann
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 28,882 Points 20k badge 2x thumb
Sure, Carrie Ann! It's JIRA PLA-30108