Force "In Progress" Call to End?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Acknowledged
Every now and again we have a call that thinks it is still in progress, but it's not. Presence on our Polycom phones and the desktop HUD also show the user on this phantom call, but RC shows the user as available in the call queue.

Since RC knows that the user is actually available the issue is just that is causes confusion with other users who think the user is on an active call. Is there any way to force the phantom call to end somehow?

Example:
A call recently came in but the caller hung up as soon as it was answered by the user "Chris". The HUD shows Chris on this phantom call.


The call log shows the call as "in progress"


And the queue member availability shows the caller as available


So, since the call isn't actually happening I don't know any way of killing the call so that Chris's HUD status shows him correctly as available.
Photo of Brandon Scivolette

Brandon Scivolette, Champion

  • 1,894 Points 1k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Danno

Danno, Champion

  • 26,484 Points 20k badge 2x thumb
Do you have Wrap up time programmed for the Queue members?
Photo of Brandon Scivolette

Brandon Scivolette, Champion

  • 1,894 Points 1k badge 2x thumb
Hi Eric,

We used to have the issue you are describing, which I've referred to as a "phantom call". It was an actual call at some point, but continues to show it as incoming.

We've done a lot of tweaking over the years to fix numerous problems, but I found the solution to be configuring our router with the port forward/triggering recommended by RC.

Between that, and one of the desktop app updates about 6 months back (which I know partially addressed that issue), we don't see those phantom calls anymore.

PS: One other contributing factor was that we had a user who worked both remotely and in the office. I found that her home and office configurations overlapped and was partially to blame as well. If you have a similar setup I can give you more info for how to resolve.
Photo of Eric L

Eric L

  • 2,546 Points 2k badge 2x thumb
We actually do have two users who tend to work remotely.  One of them uses the mobile app when working remotely, the other has an Advanced Call Handling Rule set up to bypass the desktop app & ring directly to the hardphone.

I would greatly appreciate it if you could provide some info for how to resolve this.

Additionally, the MAIN issue we're experiencing right now with Presence, is that the HUD incorrectly displays who answered an incoming queue call.  Basically, we'll see that User B answered the call, despite actually being answered by User A.  I've been working with RC Tech Support to resolve this issue, but nothing has worked so far, and we're supposedly the first & only reported case of this happening.  Have you experienced this issue before by any chance?
Photo of Brandon Scivolette

Brandon Scivolette, Champion

  • 1,894 Points 1k badge 2x thumb
Yep, same exact thing. We had that issue for years! What I can tell you is that it's a combination of the port forwarding/triggering configurations and the workaround for the user that works remotely and in the office. Port forwarding/triggering by itself did not resolve the issue for us, but once I had that "ah ha" moment about the remote user I found those issues went away.

Configuration for Remote & Office User
In our situation, when working remotely the user directly interacted with the RC desktop app to make and receive calls. When working in the office she had a Polycom desk phone.

Remote Configurations
  1. Enable 'notify desktop apps and smartphone'
  2. Disable/Off any forwarding rules for desk phones


In Office Configuration
When the user comes into the office they need to update their configurations. Again, my situation involves the user and a Polycom desk phone when in the office. It's essentially the exact opposite of the previous.
  1. Disable 'notify desktop apps and smartphone'
  2. Turn ON call forwarding rules to the desk phone
Important Note About Desktop App
Another thing we found is that when the user was in the office, and we left 'notify desktop app' enabled, it seemed to create conflict at times. I believe this is because we are using the Desktop phone to answer and receive calls, not the desktop app. You can still use the HUD and ringout functionality of the desktop app when the 'notify desktop app' function is OFF, it just won't ring the app itself. Of course, it doesn't need to since the desk phone is configured to do it.
Photo of Eric L

Eric L

  • 2,546 Points 2k badge 2x thumb
Alright, so we pretty much do things opposite of you, where we primarily use the Desktop App when we're in the office.  However, everybody using the app has it set up so that calls will first ring to the app, then forward to the Polycom after 20 seconds.  Based on your explanation, should I eliminate this forwarding so that calls only ring on one "device" (softphone/hardphone)?

Another factor to consider is that the two users who work remotely are not included in the Call Queue.  Thus, I've never seen the Presence mistakenly display that one of these two users answered an incoming queue call.  And now that I think about it, I've similarly never seen the discepency for the 3 extensions who only use hardphones.

I'll give this a shot and see if it works.  Thanks for the advice!
Photo of Brandon Scivolette

Brandon Scivolette, Champion

  • 1,894 Points 1k badge 2x thumb
I hear what you are saying. I think you are correct about the call queue, if those remote users aren't in the queue then it's likely their configuration is not part of the problem.

I know it seems complicated, but my "ah ha" moment was just a brief, and unusual, moment of clarity. When you think about the configuration where it's ringing multiple devices it starts to make sense.

Example:
Before I decided to try the remote/office user settings solution we had her 'notify desktop app' set to on when working remotely. But we also left the forwarding rules for her desktop phone enabled. So, she's working from home and receiving calls on her desktop app, but it's also ringing her desk phone in the office.

I don't think you have to be very smart to realize that the process is overlapping. While that may be something RC can do, it doesn't mean it will do it correctly every time. I theorized that, by ringing both devices at the same time, it was prone to issues with presence and phantom calls.

The possible solution you laid out sounds about right. Let RC ring the desktop app if that's what you prefer and skip ringing the desk phone.