Glip Video Calling - Black Screen When Sharing

  • 0
  • 2
  • Question
  • Updated 3 weeks ago
  • In Progress
In Ringcentral meetings, when on a video call with other staff members connected through Glip video call and I share my screen, the participant can only see a black screen. However when I initiate a meeting from Ringcentral meetings by sending a link, I don't have this issue. Is there a setting I'm missing? I seem to be the only one having this issue. 
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb

Posted 9 months ago

  • 0
  • 2
Hi Laurie, 
What OS / client versions are you using? 

If you are on MacOS Catalina, have you given RC the additional permissions that it requires for screensharing? https://support.ringcentral.com/s/article/13371-Meetings-Issue-Users-MacCatalina-not-see-others-Annotation-while-sharing?language=en_US
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
I'm on Windows 10. Ringcentral version 19.3.4
Thanks @Laurie - we will investigate it further. 
Photo of Ben French

Ben French

  • 72 Points
Hey Samudra, Laurie,

Sorry to butt in ha. I was just googling this same problem, as I seem to be the only one in my office too. It's exactly the same (where internal RC/Glip calls show my screenshare as black, but a meeting set up in Ringcentral Meetings doesn't).

I am on Windows 10
RingCentral is Version: 19.10.2 (E. 5.0.10)
RingCentral Meetings is Version: 7.0.22441.0715

Please let me know if I can provide any further information.

Many thanks,

Ben.
Thanks for that additional information Ben! We are investigating. 
@Ben / @Laurie could you please help us understand the issue better? Maybe a screen recording of what problem you are seeing? (I like Loom.com 's simple screen recording and sharing for such usecases, but whatever works for you best is fine)

Thanks! 
Photo of Ben French

Ben French

  • 72 Points
Hey Samudra,

I'll see if I can organise tomorrow at some point.

Cheers,

Ben.
(Edited)
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
I have a screenshot available right now. This is what the recipient sees. 
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
Not much to record, just a black screen. 
@Laurie - could you try updating to the latest RingCentral app? We are having trouble replicating the issue.
Photo of Crisea

Crisea

  • 60 Points
Any update on this issue?
(Edited)
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 13,768 Points 10k badge 2x thumb
This KB article may help if you're on a Mac using OS Catalina!
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
Just checking in. The issue still exists in Windows 10. Could it be a privacy setting I'm missing? Or a video card issue?
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
I found this article on zoom: The black screen during screen sharing could be caused by automatically switching graphic card (such as an Nvidia card which I have).
  1. Open the Nvidia Control Panel in the Windows Control Panel.
  2. Click Manage 3D Settings.
  3. Click on Program Settings under I would like to use the following 3D settings.
  4. Under Select a program to customize add Cpthost.exe from the Zoom bin directory.  What is the Ringcentral app (glip) program equivalent, I should add here?  
  5. Click Add.
  6. Find Cpthost.exe from the Zoom bin directory (located at C:/>Users>YOURUSERNAME>AppData>Roaming>Zoom>bin).
  7. Click Add Selected Program.
  8. Select Integrated graphics
  9. Click Apply.
  10. Try screen sharing again with Zoom.
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
Also, I found I can start a meeting through Ringcentral if I am on the new beta version, it just doesn't work in the now "Classic Ringcentral App". So it seems a fix will be available with the new version. 
Photo of Carla Delas

Carla Delas

  • 60 Points
I tried adding RingCentral app on program settings and its still the same. they are still seeing black screen whenever I share my screen. Any update on this?
Photo of Delphine Quach

Delphine Quach

  • 62 Points
Same issue here. Only with RingCentral Classic app, not RingCentral Meetings.
Photo of Laurie

Laurie

  • 324 Points 250 badge 2x thumb
Hi there. So we were able to fix the issue by turning off "Enable screen sharing with GPU acceleration" in the Ringcentral app preferences >Video Meetings>Video Settings>Edit>General.The ability to screen share inside Glip with other colleagues now works. A couple of notes if this simple process doesn't work for you, we also made changes prior which may be required including upgrading to the new version of Ringcentral. Also, the user has a Nvidia Card so we followed these directions for users with Nvidia Card - https://support.zoom.us/hc/en-us/articles/202082128-Black-Screen-During-Screen-Sharing#:~:text=Windows,Click%20Manage%203D%20Settings. We're not sure if changing the setting fixed it or a combination of the above. Good luck.