Desktop App: "press 1 to connect" not working on inbound call.

  • 0
  • 3
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
I need to get the call announcement to work properly on the desktop application in order to know which line a call is coming into.  Unfortunately, the application automatically picks up the call with no announcement when I answer.

I have "Always" enabled on the incoming call announcement option in the online settings.  I don't see any setting that would govern this from the app.

Can anyone help?
Photo of YORK

YORK

  • 100 Points 100 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 0
  • 3
Photo of Kim

Kim, Alum

  • 43,320 Points 20k badge 2x thumb
York - Can you explain what you mean by announcement?
  1. Do you want the  caller to hear  an announcement before being connected to you? > see Screening Greeting and Hold Music > audio (announcement) while connecting 
  2. Do  you want to hear  an announcement (caller's name) before they are connected to you? > See Screening Greeting and Hold Music > Call Screening
  3. Are you not hearing the "press 1 to connect" prompt under Call Handling and Forwarding > Incoming Call Information? 
Photo of YORK

YORK

  • 100 Points 100 badge 2x thumb
I'm referring specifically to hearing the mailbox name on our end when answering the call, followed by the "press 1 to connect" message.  We're not getting any announcement.

As I mentioned above, we have everything set properly under settings.  On other phones, we do receive the announcement and "press 1" prompt.  The problem is only with the RingCentral for Windows app, as far as we've found.
Photo of Kim

Kim, Alum

  • 43,110 Points 20k badge 2x thumb
York - this is a known issue on the Desktop App & some mobile Apps.  Please open a web case and reference: CNV-14457