How to turn off missed calls notifications on the new ringcentral (glip) app?

  • 1
  • 9
  • Idea
  • Updated 7 months ago
  • (Edited)
i don't like this when I get notification on every missed call, which at our company is counted as missed even someone else answered.
I like my notifications only on text messages for private messages or our dispatch, billing and other rooms.
now when i see 4 notifications on my task bar no one wrote anything, its just 4 missed calls which we get like 10 per minute, and that is confusing and taking time.
there is option in preferences for missed calls and new voicemails which i turned off, but i'm still getting missed calls notifications
Photo of Edin Kajtezovic

Edin Kajtezovic

  • 430 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
  • 9
Photo of Benjamin Pina

Benjamin Pina

  • 1,038 Points 1k badge 2x thumb
Still not fixed.
Photo of Account Manager

Account Manager

  • 92 Points 75 badge 2x thumb
Yes, Still not fixed months later.  I have had to switch to Skype for interoffice messaging with my assistant, but the rest of the office still wants to use Ring Central. Unfortunately, they're not the ones who get 40 calls a day. I do not understand how selecting not to have phone notifications on the desktop app does not, in fact, turn off phone notifications. I keep checking back to see if this is fixed since I get an occasional RC Glip message that I need to respond to, but I never know if I have one unless I leave the screen up all the time on my desktop and constantly clear out the missed calls and VMs.