I can't get our Plantronics CS55 headsets to work with the Cisco SPA514G desk phones.

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Acknowledged
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution has become inactive, or information contained in this thread is no longer accurate. If you have a related question on this subject, please post a new topic.

I have trouble shooted on the plantronics website but can't find an answer to why our headsets aren't working with the Cisco deskphone.
Photo of GARDINER

GARDINER

  • 72 Points

Posted 1 year ago

  • 0
  • 1
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 17,636 Points 10k badge 2x thumb
If you are using a hookswitch - you may need to enable that feature in the Cisco hardware via console access...
Photo of KEVIN KELLEY

KEVIN KELLEY

  • 202 Points 100 badge 2x thumb
The Plantronics Savi 740s doin't work well with the Polycom phones either.  Lots of problems with trying to use the headseat with the desktop app.  Even when I plug it directly to the phone instead of the computer, it gets bad echo and sound quality.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 41,286 Points 20k badge 2x thumb
Hey Kevin,

The echo/sound quality could be network related. I would suggest making sure everything is set up properly and go from there :)

This conversation is no longer open for comments or replies.