Why am I still encountering the department prompt even though I turned it off?

  • 0
  • 5
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate. If you have questions or comments related to this to thread, please create a new topic, or post to anot

Under Incoming Call Information I've selected "never" for the department prompt, saved changes and confirmed the setting was off, however the department and press 1 prompt still occurs when I test the system. Has anyone else run into this?
Photo of jason.hilborn

jason.hilborn

  • 110 Points 100 badge 2x thumb

Posted 6 years ago

  • 0
  • 5
Photo of Desiree

Desiree, Alum

  • 7,250 Points 5k badge 2x thumb
Hi,

I'm sorry you're running into this problem. It sounds like you're doing everything correctly. The issue is on our end and our engineers are working on a fix for it.

I'll keep you posted on this thread as I hear more.

Thanks for your patience.

Desiree
Photo of hilborn.jason

hilborn.jason

  • 90 Points 75 badge 2x thumb
Hi Desiree, Curious to know if the engineers found a fix for this?
Thanks
Jay
Photo of Tim

Tim

  • 66 Points
Any updates on this problem - clearly it is a glitch on Ring Centrals side.
Photo of hilborn.jason

hilborn.jason

  • 90 Points 75 badge 2x thumb
Thanks a ton for the update! Directed Auto receptionist to my extension and grouped 4 of my employee's numbers in my alternate number slots as a work around - no prompt and correct numbers of rings this way.

Could also you have your engineers look into # of rings as well. When I direct Auto Reception to my extension # of rings setting works, however when I direct Reception to department, the department forwarding seems to be stuck on 4 rings, very similar to how dept prompt is stuck on.

Technology is fun!
Photo of Desiree

Desiree, Alum

  • 7,250 Points 5k badge 2x thumb
Hey guys,

I'm sorry - but I don't have any new information. But, once I do I will update ASAP.

Thanks.

Desiree
Photo of RC-Installer

RC-Installer, Champion

  • 27,696 Points 20k badge 2x thumb
Jason, have you found a solution.

I have a couple of ideas.

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of Noah Schubert

Noah Schubert

  • 80 Points 75 badge 2x thumb
I'm also experiencing this issue. I always get the "press 1 to connect" prompt when a call come through via a department, even with the never or non-RC phones only option selected under "play announcement before connecting".

Please let me know if there's a solution.
Photo of MonoksideC

MonoksideC

  • 60 Points
Same problem - any updates in the past two months, or an ETA on a fix?
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
I will have to check with our Tier 3 team on this. They are off today for the holiday but I'll try to find an answer as soon as I can.
Photo of Adam Darley

Adam Darley

  • 60 Points
Ours is still doing this too... Any word?
Photo of Faith

Faith

  • 60 Points
I only recently got this error. My debit card expired and had to be replaced so I thought my account was suspended or something. So I added my new debit card but could find no way to trigger the payment on my account. But that was not the problem.

Here is what I did.
I downloaded the app on my mobile phone
I clicked on "Auto-Receptionist"
I then clicked on "Greeting and Company Calls"
I de-selected "Play Company Greeting"
I selected "Connect Directly to Extension"

So now when someone calls rather than asking them to enter an extension they would like to dial, it says please hold while I connect to your party (or something like that) and then my music plays. If I don't pick up, it then plays my custom message.

It isn't exactly what I wanted because I want to NOT play the "please hold ..." message.

But it is much better than my callers being prompted for an extension that I never provided them.

Hope that helps someone.

Faith
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Official Response
Hi all - is anyone still experiencing this? You may need to turn off "Play announcement before connecting" for Call Queue (fka Department) calls under My Settings > Call Handling & Forwarding > Incoming Call Information. Why we bury this setting in User Settings, as opposed to Call Queue Settings, I don't know, but that's where it is.
Photo of Lee HIcks

Lee HIcks

  • 62 Points
I'm not for sure if the GUI has changed since some of the earlier posts. I know the youtube video doesn't match what is in the GUI.

As Ben Foster pointed out settings for this are in the Incoming Call Information. Pay close attention as under the "Play announcement before connecting" there are actually two seciton, "Direct Calls" and "Queue Calls".

Direct calls happens if you call the extention directly WITHOUT going through the department. This is why the horrible work around of simulating a department as an extension works, no "Press 1" message, fails because only call per extention since it will be considered busy.

The part we are interested in is the "Queue Calls" section since this setting is used when a department routes a call to an extension. The options for it are "For non-RingCentral phones only" and "Always". Why there isn't a thrid option of "Never" boggles my mind. Especially since they have that setting for Direct Calls and not Queue Calls. Makes it a pain to answer a call on a cellphone while driving.

Currently in contact with tech support and they are saying it isn't possible to remove the "Press 1 to accept call" announcement when using department routing. Frustrating.....
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Lee, you are correct that this is a limitation in the product currently. I actually don't know why we offer the option to turn off "Play announcement before connecting" for direct calls but not call queue calls. We do have an engineering ticket in to address this.
Photo of Justin Pfister

Justin Pfister

  • 74 Points
Ben - any updates on getting a "Call Queue - Never Play Announcement Feature". All the other solutions seem like hacks. We have a situation where we have multiple users in a call queue and each one has slightly different caller-id requirements.. One wants to see the incoming caller ID and the other wants to see the Called-Number. this would would perfect with call queue (and I've tested it) except we can't use it because of the "press-1 prompt"
Photo of Danny Start

Danny Start

  • 484 Points 250 badge 2x thumb
Any updates on this?  I am also waiting for this fix.  All they need to do is a provide a "Never" button under call queues for that person's incoming call information setting. The reason why this is important is because it can take 10 seconds alone to redirect a call to a cellphone number, then user has to accept the call and acknowledge the call by pressing 1 and by this time the caller hangs up!
Photo of Mike

Mike, Official Rep

  • 93,798 Points 50k badge 2x thumb
Hi Danny,   This is a pretty old thread and many things have changed over the last couple of years.  Is this the setting you are looking for? 

Photo of Danny Start

Danny Start

  • 484 Points 250 badge 2x thumb
Hi Mike, no. The image above displays the option for behaviour for the caller not the queue member (employee). I am referring to caller information on a members setting. This setting is under the users call handling and forwarding tab. If a group call comes in and a member has forwarded to his cellphone, the member will have to accept the call and wait for an announcement AND then press 1 to connect to the caller. There is the option to turn it off for direct calls but no group calls.
Photo of Mike

Mike, Official Rep

  • 93,798 Points 50k badge 2x thumb
HI Danny,  Thanks for the clarification and comments above. I can understand the problem it creates if the process takes too long and the caller potentially hangs up.  If I'm not mistaken, I believe the system was designed this way so that there is confirmation that the call is being answered.  If the call automatically transfers to the cell phone number, then it's out of the RC system and all RingCentral controls and functionality are lost. 
Photo of Danny Start

Danny Start

  • 484 Points 250 badge 2x thumb
This makes a lot of sense, thanks for clarification.
Photo of Eric Stephenson

Eric Stephenson

  • 80 Points 75 badge 2x thumb
I also really need the ability to turn off "Play announcement before connecting" for call queue calls and it is a shame this is not yet available.  Please help RC Technical Team!
Photo of Justin Pfister

Justin Pfister

  • 74 Points
I also really need the "Call Queue - Never Play Announcement Feature". All the other solutions seem like hacks. We have a situation where we have multiple users in a call queue and each one has slightly different caller-id requirements.. One wants to see the incoming caller ID and the other wants to see the Called-Number. this would would perfect with call queue (and I've tested it) except we can't use it because of the "press-1 prompt".. We're forced to use the Direct to Extension option and it's really not working that well. Can we get some sort of ETA or Update on this feature request?? 
Photo of Michael S

Michael S

  • 110 Points 100 badge 2x thumb
same issue this have to be fixed finally after 12+ months !!
Photo of Eric

Eric

  • 60 Points
Bump! I am needing this feature, as one of the extensions in my queues connects to a PBX that can't dial 1 to accept the call. 
Photo of Mike

Mike, Official Rep

  • 93,798 Points 50k badge 2x thumb
Hi Eric,  This sounds like a little different request.  If you wish, you can create an new post and flag it as an "Idea" request and further explain what you want the system to do. 

This conversation is no longer open for comments or replies.