Salesforce: Incoming Call Within Salesforce

  • 0
  • 5
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I have a brand new salesforce.com org and decided to integrate with my ring central account. I followed the admin guide to a T. The first problem was chrome. It identifies the xml I import as unsafe, so you have to go up next to the favorite section where there is a shield and specifically tell it to accept it, so you guys might want to put that in your documentation.
The second and most frustrating piece is when i do a test incoming call on my own contact, the name and title doesn't appear just the number. I haven't customized the settings and even went into the call center setup under inbound call to make sure the appropriate fields are set. Why would it not retrieve the name and title of a contact when I make an inbound call?
Photo of Jordan Cashion

Jordan Cashion

  • 120 Points 100 badge 2x thumb

Posted 5 years ago

  • 0
  • 5
Photo of Mike McGibbony

Mike McGibbony

  • 70 Points
Jordan, I'm considering an integration of Salesforce to my Ring Central system?  did you get your integration to perform the way that you wanted it to do?
Photo of Jordan Cashion

Jordan Cashion

  • 120 Points 100 badge 2x thumb
Still not sure what is going on with the incoming call configuration not recognizing contact information, but the outgoing piece is working correctly.
Photo of Mike McGibbony

Mike McGibbony

  • 70 Points
Thanks, Jordan.  Is this something that Ring Central has attempted to resolve or is it been diagnosed as a bug and not solvable?  If I can seek a solution from Ring Central then I'd share it with you too!  
Photo of Bruce Bille

Bruce Bille

  • 60 Points

Jordan, what phone do you use for the Salesforce integration with RingCentral?  I use another app for sales/contact management which has dial capabilities and I want to click on a contact, hit 'dial' and let RingCentral's softphone do the work.  Is that how you've implemented this?

Photo of Marco S. Casalaina

Marco S. Casalaina, Alum

  • 950 Points 500 badge 2x thumb
To all here, it would be beneficial to you to install the new RingCentral for Salesforce if you haven't done so already:

https://appexchange.salesforce.com/listingDetail?listingId=a0N3000000B5WKqEAN

This version is much easier to set up, requires no software on the desktop at all and supports Macs too.
Photo of FireFishMike

FireFishMike

  • 192 Points 100 badge 2x thumb
https://appexchange.salesforce.com/listingDetail?listingId=a0N3000000B5WKqEAN

it's a dead entry on the Salesforce AppExchange. :-( 
This version is much easier to set up, requires no software on the desktop at all and supports Macs too.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 62,348 Points 50k badge 2x thumb
Hi Michael,

This is an older post which may be why the link isn't working. If you're looking to learn more about the Salesforce App Exchange check out this link
Photo of Mike Samos

Mike Samos

  • 122 Points 100 badge 2x thumb
Marco, I am pretty sure that most all of us have downloaded that version. The question was how do we get our SalesForce to do a screen pop of the client that is calling us. When one of my clients call, I would like to see his contact page pop up as I was told that RC had this capability. Please advise. 
Photo of Marco S. Casalaina

Marco S. Casalaina, Alum

  • 950 Points 500 badge 2x thumb
Mr. Samos,

You can indeed turn on a screen pop when a client calls you. The key to setting it up is ensuring that your Softphone Layout in Salesforce is set up correctly. For directions on how to get it to pop, have a look at the Admin Guide here:

https://netstorage.ringcentral.com/guides/sfdc_admin_guide.pdf

You'll find the setup steps for the Softphone Layout starting on page 5 of that guide.
(Edited)
Photo of FireFishMike

FireFishMike

  • 192 Points 100 badge 2x thumb
.... and what about for Lightning users?
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 62,348 Points 50k badge 2x thumb
Hey Michael, does this KB article help you?
Photo of Josh Melick

Josh Melick

  • 80 Points 75 badge 2x thumb
I have done the Softphone setup, but I believe the original issue is still a bug / not solved - matching incoming call to existing records. Salesforce defaults for US phone numbers to dropping the 1 in front, which causes the RingCentral system to not match. This is contrary to what it says in the Admin setup guide.

Please fix!!!
Photo of Mike

Mike, Official Rep

  • 93,668 Points 50k badge 2x thumb
Hi Josh,  Sorry for the delay. Just wanted to let you know that I'm looking into this.  
Photo of Mike

Mike, Official Rep

  • 93,668 Points 50k badge 2x thumb
Hi Josh, I received an update there there was recently a new version of the app released last week.  Can you make sure you are using the latest version. He did some testing with/without the "1" and it was working correctly on this end. 

Mike 
Photo of Josh Melick

Josh Melick

  • 80 Points 75 badge 2x thumb
Thanks Mike. Yes, I just got off the phone with my implementation consultant, he applied the new version and now it works as advertised. Thanks for checking!
Photo of Mike

Mike, Official Rep

  • 93,668 Points 50k badge 2x thumb
Happy to help!  Thank you for the follow up!  

Mike 
Photo of Alex Hower

Alex Hower

  • 524 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Matching Incoming Calls with a 1 to Salesforce Records.

We just integrated with Salesforce, and to test it I called myself. The visualforce page (from the old setup where it lets you pick which new object you'd like to create) popped up perfectly. I created a lead with my name, I had to manually type in the phone number (as opposed to it getting autofilled from the call which would be nice) but regardless I saved it. Then I called back again, expecting the lead I created to pop up. But it didn't, it thought I was a new lead. I realized it was because my caller id showed a 1 in front of my cell number and in Salesforce it auto corrects the phone number field on the records to not show 1s. You guys need to adjust the search parameters to include all phone numbers and all numbers with a 1 in front of it. Please and Thank You --Alex
(Edited)
Photo of Mike

Mike, Official Rep

  • 93,708 Points 50k badge 2x thumb
HI Alex, see my post above. There were other users with this issue and they just needed to update the app. 
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
Mike,

I just installed the app a few days ago (so I have the updated version) and am still having the same issue.  Is this an easy fix I can do myself or do I need to get salesforce tech support to do it?
Photo of Mike

Mike, Official Rep

  • 93,708 Points 50k badge 2x thumb
Hi Jeffrey,  This topic has strayed a bit from the original post. Can you clarify exactly what issue you are having and we'll get the right person to assist? 

Mike
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
I installed the ring central app into my salesforce, created a test lead using my mobile phone number as the leads phone number. I am able to click to dial out to the lead just fine. When I call from my mobile into my ring central, salesforce shows I have an incoming call but doesn't pop the lead detail page (as I set it to do in the soft phone layout) because the caller ID in the ring central soft phone shows a +1 before the phone number but the salesforce phone lead field doesn't contain the +1 so the system can't make the match between the caller ID and the existing lead.
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
So my tech support case was opened 11/19/15 for this issue.  We did a screen share so I could show tech support what was happening and none of his "fixes" made a difference.  I was told it was beyond what the tech support person was able to do and was supposed to be elevated to a higher tier and I was told I'd receive a call within 24 to 48 business hours.  So yesterday (11/23/15) I had not yet received a call so at the end of the business day I called tech support and the person who answered did another screen share, tried all of the same fixes, and again nothing worked so he elevated it to tier 3 and told me I'd receive a call today.  So of course, based on past experience, I doubted I'd receive a call and took the initiative and called tech support.  After informing the person who answered this time that I was not willing to do a screen share with her again because I'd already done 2 of them I was told that the case was again being elevated to the integration department (not sure there even is one based on all of the complaints I've seen on the forums) and that I'd have to wait another 48 hours.  Problem is in 48 hours it'll be Thanksgiving.  

I HIGHLY ADVISE STAYING AWAY FROM THIS COMPANY.  THEIR PRODUCT IS MEDIOCRE AT BEST AND THEIR CUSTOMER SERVICE IS NON-EXISTENT!!!  AND IF THEY CANNOT EVEN PROPERLY INTEGRATE THEIR SERVICE WITH SALESFORCE CRM THEN WHY WORK WITH THEM AT ALL???

I'm going to go check out another service, not sure which one yet but a few look promising and have much higher customer satisfaction ratings and reviews.  Ring Central barely has 2.5 stars, there are plenty of apps with 4.5 to 5 stars and over 100 reviews.  Why deal with all of the headache when they won't even help to fix it in a timely manner?
Photo of Jitender Kumar

Jitender Kumar, Director Application Development

  • 1,708 Points 1k badge 2x thumb
Hello Jeffery, 

Do you have a Salesforce Softphone layout configured?  If it is then what are settings you are using, for example when no match found, single match found, multiple match found etc. The RingCentral App send unformatted number to Salesforce for search even though the number displayed on the App has a +1.  

Try a Salesforce search (outside of the App ) for the unformatted phone number. You should see your lead in search results. That's what the App does 

Please let me know how it goes and we can assist further if needed
(Edited)
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
Yes, I have a salesforce softphone layout configured.  The settings for rules when no match found, single match found, etc... are irrelevant, the app cannot find the phone number.  I know I can manually search for the phone number (which I did just to ensure Salesforce's search function wasn't the issue) and it worked fine but the app is supposed to do this, I shouldn't have to do it myself.  The bottom line is the app doesn't work as advertised as you can see from the complaints on the forum.  And the bigger problem at the moment is that RingCentral customer service/tech support has wasted so much time that I'm forced to look for another phone provider because I can't wait another 5 days for this to still not work properly when I can just get a system installed that works from the start rather than wasting so much time with tech support that doesn't even call back when they say they will. 
Photo of Jitender Kumar

Jitender Kumar, Director Application Development

  • 1,708 Points 1k badge 2x thumb
Hello Jeffrey, 
Once again sorry for the trouble you are having. The scenario you are describing appears to be working for me. Could you check if the Softphone layout is assigned to you profile?  I can do a screen share to troubleshoot.  

Was there a case# provided to you, I can dig deeper to see what happened and why did someone not called you back when promised.
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
Hello Jitender,

Thank you for the follow up.  The case number is 04136282.  I'd be happy to do a screenshare if you can get it working.
(Edited)
Photo of Jeffrey Wood

Jeffrey Wood

  • 102 Points 100 badge 2x thumb
Thank you Jitender!  For anyone following this thread still, within 5 minutes of Jitender's call the problem was solved.  It was an easy fix, so I'm not sure why the Ring Central tech support team couldn't get it done sooner but I'm glad it's fixed none the less.

Just so everybody knows, in Salesforce, when you create your softphone layout, you need to then "setup", "call center", "soft phone layouts", then click the "soft phone layout assignment" tab, and be sure to assign your profile to the softphone.  Then click the "edit" tab, and click the "default" check box just to be sure it stays assigned.  Once this was done my lead detail page popped when I sent my test call through.

Jitender, in the future I'd advise you have your tech support team add this to the list of fixes they try when someone calls with this problem.

Again, thank you.
Photo of Jitender Kumar

Jitender Kumar, Director Application Development

  • 1,708 Points 1k badge 2x thumb
Thank you Jeff. I am glad it worked out.  I question the user friendliness of Salesforce screen, You see there was only one profile that you created, the dropdown on Salesforce screen should not have an option of default when there is no such profile. 

Anyway, I have sent this info to our concerned department to add to our knowledge base. 
Photo of Mike

Mike, Official Rep

  • 93,708 Points 50k badge 2x thumb
Official Response
Jitender, thanks for your assistance, and Jeffrey thanks for posting the solution!

when you create your softphone layout, you need to then "setup", "call center", "soft phone layouts", then click the "soft phone layout assignment" tab, and be sure to assign your profile to the softphone.  Then click the "edit" tab, and click the "default" check box just to be sure it stays assigned.  Once this was done my lead detail page popped when I sent my test call through.
Photo of Mike

Mike, Official Rep

  • 93,708 Points 50k badge 2x thumb
RingCentral is looking for a few Beta Testers to participate in the RingCentral Salesforce Lightning BETA.   For more details and to sign up, please click the link below. 

RingCentral for Salesforce Lightning BETA