Why do I have problems using the Softphone on my computer?

  • 0
  • 1
  • Question
  • Updated 7 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate.  If you have questions or comments related to this to thread, please create a new topic, or post to anot

Hi,


I have so much problem connecting my computer to the RingCentral Softphone software. There are cases when the software shows status of "Not signed in". Every time when I try to click sign in the software doesn't have any response. This problem is temporarily solved by disconnecting and re-connecting to the network to force the software to react but this is really an ignoring "band-aid" solution. Does anyone have the same problem and are there any solutions to it?


Many thanks!
Photo of Anthony Pang

Anthony Pang

  • 80 Points 75 badge 2x thumb

Posted 7 years ago

  • 0
  • 1
Photo of RC-Installer

RC-Installer, Champion

  • 27,914 Points 20k badge 2x thumb
Hi Anthony, the first thing is what is the network like that you are connected to? How complex, is it.

The Softphone only needs a few things to get connected, open ports 5060 - 5090 UDP and a SOLID connection to the network.

I would start by connecting your PC to the simplest of setups. Like plug directly in to your broadband modem if you are at home etc...

If you could share what you know about the network, then it would help solve the issue.

If you want to talk, just give me a call
630-975-1200
Thanks

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of Ken johnson

Ken johnson

  • 540 Points 500 badge 2x thumb
Can you define "solid" please? I have been in it management for 20 years and I don't know what you mean. Bandwidth? Packet loss? Raw speed? Latency?
Photo of Anthony Pang

Anthony Pang

  • 80 Points 75 badge 2x thumb
We have a router that directly connects to the main modem of the building. The modem also supports Wifi network so I can connect either one of those. I am using a PC laptop which wirelessly connected to the network and the network is always excellent.

It only occurs every time when starting up the softphone software.The status will either stuck on "Not signed in" or "Unable to connect - Connection failure".

I have no control over the router so I am not sure how to change the port, but if you are talking about the local port it's always 32 even if I tried to change it to something else.

It's not urgent after all and I am just curious about it.

Thanks!

This conversation is no longer open for comments or replies.