Calls are incorrectly routed based on time of day.

  • 0
  • 2
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate. If you have questions or comments related to this to thread, please create a new topic, or post to anot

I've told the RingCentral system what time zone I'm in but the system continues to handle calls incorrectly based on the time of day.


I've opened a case with the support team. They looked at my setup, tested it out and then acknowledged that this is a known issue but they don't seem to think it's a big deal. There suggestion was to change our business hours to be open 24 hours a day. That's not an acceptable solution for us! So incredibly frustrating.


Has anyone else had this issue and if so, have you found a workaround?
Photo of Ross

Ross

  • 152 Points 100 badge 2x thumb
  • frustrated

Posted 6 years ago

  • 0
  • 2
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Hi Ross, is this an issue on all of the phones?

What are the details on it not working? Is it specifically 1 hour or 2 hours off or is it ramdom?

Is time in sync on the phones?

I am a certified Installed of RC and am here to help.

You could reach out to me directly if you like

ckfuscone@yahoo.com

Chuck
630-975-1200
Photo of Desiree

Desiree, Alum

  • 7,270 Points 5k badge 2x thumb
Hi guys,

Looks like this is a known issue, Chuck. Have you seen this before?

Ross - I found your case and looks like the agent you worked with submitted this as a known issue.  I'm sorry you have to deal with this right now and promise to to keep you posted when we have a resolution.

Thanks.

Desiree
Photo of Ross

Ross

  • 152 Points 100 badge 2x thumb
Hey Chuck,

We have a professional plan and no physical phones, everything is routed to our cell phones. This makes our lives a little simpler as we can conduct our business on the move. However, the last thing I want is business phone calls being routed to my employees cell phones at 2am because RingCentral's suggestion was we have our phone lines open 24 hours a day.

Desiree,

Thanks. I look forward to hearing back from you guys on a solution to this bug.

Thanks,

Ross
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Ross, not sure if it is a bug, I have many customers with time of day logic that works to the minute...

Would you be open to me logging in and looking at the configuration?

It always helps to look at how things are setup.

Let me know

Thank you
Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
630-975-1200
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Ross, not sure if it is a bug, I have many customers with time of day logic that works to the minute...

Would you be open to me logging in and looking at the configuration?

It always helps to look at how things are setup.

Let me know

Thank you
Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
630-975-1200
Photo of Ross

Ross

  • 152 Points 100 badge 2x thumb
Update: Today I realized that there are regional settings at the Auto-receptionist level, the department level and the individual employee level. My regional settings were not consistent across the board, some was east coast time others were west coast time. I'm hoping that I now have them setup correctly that this will fix my issues.

Second thing I noticed today: If you select Central Time Zone, the drop down box will tell you that you selected Saskatchewan. However, if you click on Saskatchewan then the system tells you that you selected the Central Time Zone. So I've switched everyone to Saskatchewan (Displays as Central Time Zone). Hopefully this also helps with my issue listed above.
Photo of Ross

Ross

  • 152 Points 100 badge 2x thumb
Chuck,

Thanks for offering to look at our setup. If my updates from above don't fix the issue then I'd love for you to take a look. I'll be in contact if this doesn't get resolved.

Thanks,

Ross
Photo of Dan Sommerfeld

Dan Sommerfeld

  • 138 Points 100 badge 2x thumb
I am having the same issue and my corporate parent is on my ass to fix it. I may have to dump RC. What is going on here? Why is this so hard to diagnose and fix?
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Dan you need to check the regional settings on ALL extensions and call queues. Some where there is a mis configuration. I just fixed this for one of my customers today

Let us know

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Yes, you can have time-of-day settings configured at the company level as well as the individual user level. You should check both areas of Settings (Phone System and each User's settings) to see where you have time-based routing rules set up.

This conversation is no longer open for comments or replies.