Mobile App: Does Not Ring

  • 1
  • 7
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution has become inactive, or information contained in this thread is no longer accurate. If you have a related question on this subject, please post a new topic.

Installed app on my iPhone, then I call the number to test... no ring.
Photo of Paul McGarr

Paul McGarr

  • 340 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
  • 7
Photo of Larry Solheim

Larry Solheim

  • 598 Points 500 badge 2x thumb
First thing I would do if you are trying to use the app on 3G or 4G need is to verify that option is turned on. It may be set to only allow calls on Wi-Fi. You will find the allow calls on 3G/4G me in the settings. Other than that I would call Support I'm sure they could fix it for you.
(Edited)
Photo of Paul McGarr

Paul McGarr

  • 340 Points 250 badge 2x thumb
I have 3G/4G enabled but am also on WiFi. Support may be able to help but wait time is so long I get angry and hang up. I've waited 40 minutes, only to get disconnected. Will not do that again.
Photo of Larry Solheim

Larry Solheim

  • 598 Points 500 badge 2x thumb
I would also verify that your settings in the online control panel are set properly. I would check under call handling for the line you're trying to work with to see if there any options there. Otherwise I would delete the app and try and reinstall it then make sure you're signed in. I wouldn't get discouraged, lots of people use the app every day. Normally it is much easier to get into support, although it's frustrating they are your best source of help.
Photo of Paul McGarr

Paul McGarr

  • 340 Points 250 badge 2x thumb
I checked everything I read to check, both online and in the app. I also uninstalled and reinstalled the app. Just doesn't ring/vibrate/notify, etc. I can make a call without issue.
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
What does your call log say?

Do you have the notify smart phone set to yes in call handeling?

Chuck
Certified Ring Central Installer
Photo of Paul McGarr

Paul McGarr

  • 340 Points 250 badge 2x thumb
Yes, and zero second wait.
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Do you have your Phone logged in as the extension you are sending the call to or are you forwarding the call out to the cell?

I could do a team viewer session and probably fix it

Let me know

Chuckfuscone@gmail.com

Certified Ring Central Installer
Photo of Paul McGarr

Paul McGarr

  • 340 Points 250 badge 2x thumb
Not forwarding, trying to use softphone app on cell phone, not cellular call with native phone app.
Photo of Larry Solheim

Larry Solheim

  • 598 Points 500 badge 2x thumb
You sound pretty savvy so I am assuming that you checked the notifications option on your iPhone to make sure notifications for the RingCentral app are on. Also I would close all the apps on your phone shut your phone off and turn it back on. Then start RingCentral. I have found that cured many notification problems on many apps.
Photo of RC-Installer

RC-Installer, Champion

  • 27,716 Points 20k badge 2x thumb
Just google Teamviewer.  Latest version is 9 I think.  It is free.

Teamviewer.com

I am back now and should be here for a while at that number

Chuck
Photo of Tony Dye

Tony Dye

  • 360 Points 250 badge 2x thumb
I may be seeing a variant on this. When the iPhone is locked, there is no audible ring, just a screen notification. If the iPhone is unlocked, I get audible. Curious.
Photo of Kim

Kim, Alum

  • 43,774 Points 20k badge 2x thumb
1) Under Call Handling & Forwarding in your Settings online, make sure Desktop App & Smartphone is turned ON. 
2) Log into app on iPhone with your Digital Line (NOT the main number and extension). 
3) Make sure VoIP Calling & Accept Calls is turned ON inside the cell phone app. 
4) The cell phone cannot be on silent or vibrate if you want an audible tone. As long as the app is running in the background and it's not on silent, it should ring.  

Try and test.
(Edited)
Photo of Tony Dye

Tony Dye

  • 360 Points 250 badge 2x thumb
It gets even more interesting. If I tap the power button, so the phone is in the "slide to unlock" condition, but hasn't actually locked down requiring login, it still rings. But if it gets to the point of needing the passcode (or fingerprint, etc.) then it doesn't ring. So, seemingly I can have security, or a ringing phone, but not both.
Photo of Mike

Mike, Official Rep

  • 93,928 Points 50k badge 2x thumb
Hi Tony, Can you try to uninstall and reinstall the mobile app and test it again.  If it still does the same thing can you open a case and be sure to include what model of phone and which iOS version you have. Open a Case
Photo of Tony Dye

Tony Dye

  • 360 Points 250 badge 2x thumb
In our brief testing today, it does seem to be working now! that's great progress. We have noticed that for a couple of our users who use Apple Watch that the notify via the watch is still a problem, but we have seen the answer to that.

Thanks Mike!
Photo of Lucas Shelton

Lucas Shelton

  • 102 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Doesn't always ring with iPhone.

The app doesn't always ring on my iPhone.  I'd say one out of every five calls I'll miss because it doesn't ring my phone/app.  Just a bit ago I looked and it showed a missed call on Ring Central, but the phone didn't actually ring.  It was sitting right beside me with the ringer on. 
Photo of Billy O'Neal

Billy O'Neal

  • 1,300 Points 1k badge 2x thumb
I've seen this same behavior when I was using the iPhone app. As far as I could tell, it had nothing to do with my RC settings. If I hadn't used the app for a few hours, calls would stop coming through until I relaunched the app.  Maybe iOS is shutting down some service to save battery?  Since switching to android I've never had this issue.
Photo of Kim

Kim, Alum

  • 43,774 Points 20k badge 2x thumb
Lucas - Billy is correct, if all of your settings are correct (listed above) then it's an issue with the phone.  Please do a hard reboot on the iPhone and see if that helps. Also have you contacted support, what is the case number? 
Photo of Lucas Shelton

Lucas Shelton

  • 102 Points 100 badge 2x thumb
Ahh yes, the good ole "pass the buck."  I haven't opened a case yet, I'll do that when I have time.
Photo of Lucas Shelton

Lucas Shelton

  • 102 Points 100 badge 2x thumb
I don't know why my question was moved to this thread.  I realize the issue is a similar issue, but I've tried all the above to no avail.  I need help as this is causing me missed calls, which is causing me missed leads, which is causing me missed dollars.  I need this solved ASAP as it's affecting my bottom line.  There are a hundred companies just like Ring Central I can take my business to.
Photo of Henry Butz

Henry Butz

  • 120 Points 100 badge 2x thumb
This sounds identical to the problem I had with my IP phone not ringing.  It was on the other side of my router.  I could make calls but it would not ring for incoming calls.  What I did to fix it was add UDP port forwarding through the router to a static IP address on the phone.  Then the phone would ring.  It may be a similar issue for the phone app if you are sitting on the LAN via WiFi.  UDP packets are typically blocked by the router if I am not mistaken.
Photo of Hannah Fliesler

Hannah Fliesler

  • 72 Points
I have the same issue, I keep missing calls as well even with following the above. It is a little embarrassing to realize a client called me 4+ times through the week and I didn't realize until they finally sent me an email. I would say I get about 1/5 out of every call where t actually rings and I see it displayed on my phone. Can someone help me?
Photo of Brandon

Brandon, Champion

  • 24,596 Points 20k badge 2x thumb
Official Response
This issue is most often related to using a low end home/soho router/firewall/integrated wifi type device.  Many of these routers timeout sessions due to lack of resources or are just poorly designed.  This explains why Henry was able to get his to work with port forwarding.  However, what would he do if he had more than one phone?  You can only forward ports to one IP address.

Anyhow, to test this and prove this point, turn off wifi on your phone and test with cellular data.  Also, check your app settings and ensure voip calling, incoming voip calls and over 3G/4G are all enabled.  If that works and wifi doesn't then you know the issue is with your local network gear.

If you determine it is with your gear, you can research fixes, try updating firmware or replace.
(Edited)
Photo of Hannah Fliesler

Hannah Fliesler

  • 72 Points
I use cellular data all of the time, never wifi. I checked the settings too, they're all set to the appropriate settings.
(Edited)
Photo of Mike

Mike, Official Rep

  • 93,928 Points 50k badge 2x thumb
Official Response
Good advice bjsvec!!!  Thanks

If you've tried mjsvec's suggestion (also check router configuration), then it would be helpful to know if the calls going to voicemail?  Double check that you don't have any rules that are sending it to VM or forwarding elsewhere etc.   If you still have problems, then open a case and provide the phone number, screenshots of the call logs with times & dates etc.

1) Under Call Handling & Forwarding in your Settings online, make sure Decktop App & Smartphone is turned ON. 
2) Log into app on iPhone with your Digital Line (NOT the main number and extension). 
3) Make sure VoIP Calling & Accept Calls is turned ON inside the cell phone app. 
4) The cell phone cannot be on silent or vibrate if you want an audible tone. As long as the app is running in the background and it's not on silent, it should ring.  

(Edited)
Photo of Kim

Kim

  • 72 Points
I understand the directions above, but would like to have both the RC app *and* my handset ring simultaneously. It seems that the order in the "Call Handling & Forwarding" only allow for the app to ring FIRST -- and THEN the handset. The "ring simultaneously" settings do not seem to apply to the RC mobile app. How can I adjust the settings, so that the mobile app and the handset ring at the same time?
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 36,908 Points 20k badge 2x thumb
Kim,

Simply set the "Wait" time to 0 (zero) seconds. They will all ring at the same time.
Photo of Kim

Kim

  • 72 Points
Interesting! So the RC mobile app will still keep ringing, even though the workflow indicates that it will forward the calls to whatever is next in the list? It was my understanding that the mobile app would ring, then stop -- once the "wait time" expired and it moved to the next step in the workflow.

This conversation is no longer open for comments or replies.