Mobile app: What are the minimum requirements?

  • 1
  • 4
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: outdated info

On Google play, when I search for "ringcentral", I find the RingCentral app, but it says "Your device isn't compatible with this version."

I got my android phone this year -- not that old -- but it's a Motorola Admiral (model XT603), running Android version 2.3.5.  Is there an app for this?
Photo of LovisMirac@aol.com Ivison

LovisMirac@aol.com Ivison

  • 130 Points 100 badge 2x thumb
  • Pessimistic

Posted 3 years ago

  • 1
  • 4
Photo of Kim

Kim, Alum

  • 43,320 Points 20k badge 2x thumb
Official Response
RingCentral  will only work on Android on 4.4 or higher.

UPDATE: RingCentral recently released a critical update to our RingCentral Android mobile. As of November 22, 2015, users on version 7.4.2 and earlier, will be unable to use the mobile app without first upgrading. Be sure to download the latest version today.
(Edited)