Language changing for RingCentral on browser.

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I use RingCentral in the U.S. and my login screen is automatically switching from English to German, when I change the language on the top right it switches back to German. This happens in the browser and I can barely manage to send or receive faxes with another language even if I know where certain actions are located.
Photo of Jose Quijano

Jose Quijano

  • 92 Points 75 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 0
  • 1
Photo of Dierdre

Dierdre

  • 844 Points 500 badge 2x thumb
Try changing the Language settings of your browser. If using Google Chrome, you can try these steps:

1. Go to chrome://settings/
2. Click Settings
3. Click Show advanced settings which is at the bottom of the page.
4. Look for Languages.
5. Click Language and input settings...
6. You will see these options (see image below).
 
7. Delete German (if present). Add English (if not present).
8. Click English, then click Display Google Chrome in this language.
9. Click Finish.

I hope this helps. :)
Photo of Jose Quijano

Jose Quijano

  • 92 Points 75 badge 2x thumb
Only English appears, it is not my browser changing, it is the RingCentral webpage that changes.
Photo of Mike

Mike, Official Rep

  • 90,988 Points 50k badge 2x thumb
Hi Jose Quijano ,  Our web page isn't publish in German (English only).  So, there would be something on your browser or computer causing this. 

Try the steps on this page and let us know what happens.  https://productforums.google.com/forum/#!topic/chrome/RhxuggahkJc

Mike 
Photo of Dierdre

Dierdre

  • 844 Points 500 badge 2x thumb
I see. You could probably try the steps in this RingCentral article:

Changing the Language Settings from English to a Local Language
https://success.ringcentral.com/articles/RC_Knowledge_Article/8857#OnlineAccount
Photo of Jose Quijano

Jose Quijano

  • 92 Points 75 badge 2x thumb
I tried doing this but there is not Admin Portal at the top, therefore I cannot choose the Users and change the regional settings. I have made the change and it seems to work now. It is solved. Thank you!
(Edited)
Photo of Mike

Mike, Official Rep

  • 88,774 Points 50k badge 2x thumb
If it's the login screen it's probably the drop-down you were referring to above.  
Did you try clearing your cache and cookies yet?  How do I clear my cache and cookies in my web browser?

Does this happen on all browsers or just a specific one?
(Edited)
Photo of Dierdre

Dierdre

  • 844 Points 500 badge 2x thumb
Glad to help, Jose. :)

Mike's suggestion is also applicable when other websites do not load well, or when some parts are missing. :)
Photo of Mike

Mike, Official Rep

  • 91,080 Points 50k badge 2x thumb
Sorry.. I misunderstood which page was changing.  For the login screen, yes, use the drop-down at the top.  If it keeps changing it's probably a browser caching issue.  If it still persists, let us know. 

Mike