latest desktop app crashes during opening

  • 0
  • 4
  • Question
  • Updated 7 months ago
  • In Progress
On windows 7 computer, after installing the latest Ring Central Desktop, the application fail to launch. When you double click the icon to start, crash report will pop up saying, abnormal termination. 

Before the crash report error, I was seeing "this application failed to launch QT (blah blah, i don't remember the exact message)" 

Any help on this question would be nice as the application just won't launch at all to use. 
Photo of Jae Wook Kim

Jae Wook Kim

  • 114 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 4
Photo of Shelly Roth

Shelly Roth, Champion

  • 2,042 Points 2k badge 2x thumb
i tried downloading the update as well and it's not working correctly for me either.  In fact, when I restarted my computer it seemed to revert back to the prior version.  I decided not to download it because for the time period I did have it downloaded, it was not connecting to my Outlook contacts and I need those in order to work efficiently.  I have Windows 10.  

I have created a support ticket for this issue, but have yet to get someone to figure it out for me.
Photo of Saadet

Saadet, Employee

  • 69,132 Points 50k badge 2x thumb
Hi Jae and Shelly,

I see you both have Support Cases open. Please keep us apprised and let me know if you feel like you aren't getting the service you need you can reply back here or email us at 
Photo of Tom Rex

Tom Rex

  • 470 Points 250 badge 2x thumb
I'm on Windows 10. Mine crashed again today. This happens often. I have to uninstall (no repar feature) and reinstall again.
Photo of Jeremy Elam

Jeremy Elam

  • 62 Points
I have a user on Windows 10 that this keeps happening to as well. I have done a complete uninstall and went as far as to remove any traces of it including from the registry as well and then tried to re-install with older client and the latest client. Still get the same thing
Photo of Saadet

Saadet, Employee

  • 68,888 Points 50k badge 2x thumb
Hi Jeremy, please contact our Support Team. They can verify if it is app related or not. It's possible that something on your computer is causing an issue
Photo of Dave Cochran

Dave Cochran

  • 60 Points

I have a Win 10 user that gets a cant connect to the network when he tries to open Meetings??

When he tries to open the desktop app it just spins for a whole then give us the same message.
I remove it from every where including the registry and there is no change. HE cant use this App at all

Very Frustrated
Photo of Saadet

Saadet, Employee

  • 67,790 Points 50k badge 2x thumb
Hey Dave, we'll need to have our Tech Support Team look into it. Please either give 'em a call or start a chat with them :)
Photo of Brad Krivelow

Brad Krivelow

  • 60 Points
I have a user reporting kind of the same issue. He will randomly get an abnormal termination crash window. No real rhyme or reason.

Photo of Becky - Community Support

Becky - Community Support, Official Rep

  • 1,372 Points 1k badge 2x thumb
Brad, we'd recommend working with our Support Team by opening a case.