Lync not registering

  • 0
  • 1
  • Question
  • Updated 5 years ago
Merged

This conversation has been merged. Please reference the main conversation: Help with Unsupported or 3rd party equipment.

I am unable to get Lync to sign-in on my VVX 500 using 5.2.0.8330.  To validate my credentials and that Lync was reachable, I used this following Python script:

https://gist.github.com/msmorul/7902330

Output below:
--1. GET: https://lyncdiscoverinternal.REMOVED.net/
--Response Code: 200
--2. GET: https://lyncwebsvl.REMOVED.net/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=REMOVED.net
--Response Code: 401
--3. POST: https://lyncwebsvl.REMOVED.net/WebTicket/oauthtoken
--Response Code: 200
--4. GET: https://lyncwebsvl.REMOVED.net/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=REMOVED.net
--Response Code: 200
--5. GET: https://lyncwebsvl.REMOVED.net/ucwa/oauth/v1/applications
--Response Code: 201
--6. GET: https://lyncwebsvl.REMOVED.net/ucwa/oauth/v1/applications/103606586670/people/contacts
--Response Code: 200

Couple of questions:

1) Does anyone have details to exactly how the VVX 500 attempts to sign-in?  (e.g. Which URL's it calls, does it support discovery, ...etc).

2) Could anyone suggest another software release I might have better luck with?

Thanks!
Photo of Eddie Parra

Eddie Parra

  • 92 Points 75 badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of Eddie Parra

Eddie Parra

  • 92 Points 75 badge 2x thumb
I just realized the Github script defaulted to "lyncdiscoverinternal" instead of "lyncdiscover".  I am not familiar with Lync enough to understand the difference, but I am attempting to sign-in from an IP phone at my home and not within my employers network.  Here is the output with "lyncdiscover" enabled.

--1. GET: https://lyncdiscover.REMOVED.net/
--Response Code: 200
--2. GET: https://lyncwebsvl.REMOVED.net/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=REMOVED.net
--Response Code: 401
--3. POST: https://lyncwebsvl.REMOVED.net/WebTicket/oauthtoken
--Response Code: 200
--4. GET: https://lyncwebsvl.REMOVED.net/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=REMOVED.net
--Response Code: 200
--5. GET: https://lyncwebsvl.REMOVED.net/ucwa/oauth/v1/applications
--Response Code: 200
--6. GET: https://lyncwebsvl.REMOVED.net/ucwa/oauth/v1/applications/103606586670/people/contacts
--Response Code: 200

Thanks!

This conversation is no longer open for comments or replies.