Mobile App: not ringing while phone asleep

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)

case #05547327

I have a iPhone 4s but this  problem seems to happen no matter what the phone as I tried it on a 5c. the problem is it doesn't ring when the phone is asleep for a few minutes and if it does it is after the caller is already getting the voicemail greeting. I have the ring length set to 30 seconds and I have tested it with the tech support and they sent me to this forum.

"this is regarding Mobile app issue and I'm reaching out to you to inform you that we have checked this issue with our products team and found its a product limitation and no work around is available to it. "

Anybody have this issue? Solution? It only seems to be with this one extension. I have created a new extension (it is a "virtual extension" meaning no direct number) and it gives me the same problem. It rings right away with the desktop app. The tech had me change the notifications on the iphone to alert instead of banner and deleted and reinstalled the app. logged into another extension and gave the same problem. 

Have not reset the phone which would be a real hassle. 

Photo of JOSEPH

JOSEPH

  • 456 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Luke

Luke, U.S. Tier 1 Support

  • 3,774 Points 3k badge 2x thumb
Hi Joseph, it turns out that you cannot do this with an iPhone 4S. The limitation is that Apple has not upgraded the software for the iPhone 4S to iOS 10. If you are up to date on your iPhone 4S then you will have iOS 9. Apple introduced new features in iOS 10 that allows RingCentral to have calls show up the same way they do when you receive a call to your cellular number. Prior to iOS 10 this was not possible and you had to rely on notifications, which may not show up if your device is asleep.

In iOS 10 you can enable the integrated calling feature to make it so that all your calls show up on the screen just the same way that a call to your cellular number does. If you eventually get a phone with the ability to update to iOS 10 or greater, you can read our page on integrated calling to see how to enable this feature.
(Edited)
Photo of Brad Cunningham

Brad Cunningham

  • 110 Points 100 badge 2x thumb
will do.
Photo of Brad Cunningham

Brad Cunningham

  • 110 Points 100 badge 2x thumb
No change. I just missed another call. It did not ring. I was notifed by text only that I missed the call.
Photo of Jan Ferguson

Jan Ferguson, Champion

  • 28,256 Points 20k badge 2x thumb
Brad,

Just an FYI...Luke was absolutely correct. I am running iOS v10.3.2 on an iPhone 7 Plus and do not have this issue. I never had an iPhone with less than iOS v10 on my phone (previously an Android person) but have never had this issue with iPhone or Android phones.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 31,850 Points 20k badge 2x thumb
Hey Brad, 

Thanks for the update. All I can think of that would cause something like this would be configuration error. Have you verified that this setting is set to ?


Do you have any Advanced Rules in place?


Feel free to post screenshots of your settings and black out personal information for me to take a look at.

If nothing is off with those settings, uninstall/reinstall the app and allow all settings.
Photo of Brad Cunningham

Brad Cunningham

  • 110 Points 100 badge 2x thumb
Settings are good. No advanced rules. I just reinstalled the app again. However I did this a couple days ago also. I will let you know what I get.