Mobile App: Option to Disable Answering From Headset

  • 1
  • 2
  • Idea
  • Updated 6 months ago
I am having a issue where my bluetooth headset is auto-answering incoming calls  (support case opened, #09672638).   The issue presented itself in the latest Android RingCentral app update 19.4.11.0.004 and was never present prior to this using the same mobile device and headset. The change-log noted some new features allowing "answer calls from wired headset", so I assume that this is a bug related to that recent change.

Headset is a Plantronics Voyager Legend CS. 

Feature Request:   Perhaps my situation above is simply a device-compatibility issue (TBD), nevertheless, I think that it would be useful to have a setting option to "disable answering from wired/wireless device".  Aside from my unique(?) problem above, I can imagine situations where you may want to avoid accidental button presses on headsets.
Photo of Chad

Chad

  • 230 Points 100 badge 2x thumb

Posted 8 months ago

  • 1
  • 2
Photo of Liam Zhang

Liam Zhang, Employee

  • 852 Points 500 badge 2x thumb
Hey, We are investigating this problem with your headset. 
Photo of Craig O'Neill

Craig O'Neill

  • 494 Points 250 badge 2x thumb
I have the same issue.  I use a Jabra Evolve 75.

I've replaced my phone already, and RingCentral is the only application that auto answers.  This is not a problem with the headset.  This is a problem with the app.
Photo of Craig O'Neill

Craig O'Neill

  • 494 Points 250 badge 2x thumb
Found it was not a problem with the RC app, it was an obscure setting with Jabra.  See post below.

Advice:  Check settings on any device simultaneously connected to the headset.
Photo of Liam Zhang

Liam Zhang, Employee

  • 852 Points 500 badge 2x thumb
Update on this topic, the issue has been fixed in the latest upgrade. Please update your app to the newewst version.
Photo of Craig O'Neill

Craig O'Neill

  • 494 Points 250 badge 2x thumb
No it wasn't.  There is no update available for this app.
Photo of Craig O'Neill

Craig O'Neill

  • 494 Points 250 badge 2x thumb
My coworker has nearly an identical setup as mine, he does not have this issue.  Same headset.

There has got to be a solution with a setting or something.  Two users with two nearly identical hardware setups should be able to produce similar behavior.
Photo of Craig O'Neill

Craig O'Neill

  • 494 Points 250 badge 2x thumb
For Jabra Users:  I found the issue with auto-answering on my cell. 

I learned that the issue only occurred when I was also paired with my PC.  

There is an obscure setting on the USB dongle, accessible through your app on your PC.

You need to toggle OFF  - "Soft-phone integration (Bluetooth)" 

How this could affect behavior on my cellphone.. I cannot say.  But I am relieved to at LONG last be able to pair my headset to my mobile device and my PC simultaneously.  




Jabra Support, sadly, was no help on rooting out this issue.