Mobile App Transferring Issues

  • 0
  • 5
  • Question
  • Updated 9 months ago
  • Acknowledged
Whenever a user transfers a call on their Mobile App to another extension, it rings that user's mobile phone back after they transfer it. Is anyone else having this issue?

I've put in a case with RC about it and have given them multiple examples but they have not helped. They just keep asking for more examples?
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 0
  • 5
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Verify if they are doing a "blind" transfer or a "consultative" transfer.
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Is the mobile APP on an iPhone or Android?
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
All issues have been on an iPhone. When they go to transfer, there is no option for a type of transfer. It's just press transfer, type in the name/extension and that's it.
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Cool, I have an iPhone too.  I'm on version 9.2.1.1.15 (50.9.21.2).
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
So did a test on mine...
Answered the call
Pressed Transfer
Located the user and pressed their name
Got a pop up window asking me to verify and pressed transfer
and it transferred to the users phone (without me having to press anything)
Also received a confirmation message too.

Sound like we're both doing the same thing?
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
The particular issues that I've been experiencing have been from calls that come through a call queue
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Ohhhhhh.  Let me test that and see if can find it.  So, to confirm, the call comes into the Queue and is answered on the mobile APP - is the transfer to a user or to another Queue?
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
Transferring a call queue call answered on the mobile app to a specific user.
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Alright, I tried it and all scenario of a transfer went through OK - nothing bounced back.  Does the Call Log show anything that may explain why it's bouncing back?
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
This is a call example where it rang back. Crystal transferred the call to Jessica, but it rang her back. Everything in the log looks normal.
Photo of Danno

Danno, Champion

  • 27,966 Points 20k badge 2x thumb
Yeah, I'm stumped too.  It's probably something real simple.  What I would do next is do a test call (not through the Queue) and have her transfer to another user - and see if that works.  If it does, repeat through the Queue - and see if that works. If it does, compare the user settings against Jessica's.
Photo of Habitatbuilder

Habitatbuilder

  • 80 Points 75 badge 2x thumb
Was this ever fixed? We are new to RC and are having this issue.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hello Habitatbuilder,

We haven't received an update from John in a while. Could you provide more information and give examples of when this happens to you? Is it happening to all users or just a particular user? What type of phone do they have? What steps do they take to transfer the call?
Photo of Habitatbuilder

Habitatbuilder

  • 80 Points 75 badge 2x thumb
Sure! We had a case open that was closed yesterday because it seemed to be working okay. But now the issues are happening again. When someone calls our main line and presses 4 for customer service, there are five or six employees that ring simultaneously (not shared lines but their individual lines). One will pick up. If they go to transfer the call internally, the call rings right back to them. Sometimes when they try again it transfers and sometimes it just rings back again. This is primarily happening with iPhone softphone apps, as far as I can tell.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Habitatbuilder,

When you say transfer the call internally - where are they transferring it to? A specific user? Feel free to tell me extension numbers and I can log into your account and check settings :)
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Habitatbuilder,

I took a close look at Call Queue Ext.4 and the user's Call Handling settings. One thing that I did notice that could be causing an issue is that extensions 105 & 106 have their mobile numbers listed under Call Handling, on top of having the Mobile App set to on. So what's wrong with that is the call will be pushed not only to the RC Mobile App but also the Cell Phone itself - through its carrier. 

Another thing I noticed is that extension 115 is part of the Call Queue. Now, extension 115 has a Ring Group set up that includes the other members from the Call Queue. This could be causing a lot of issues potentially. Especially if someone from the Call Queue is transferring the call to extension 115, which then will ring their phones/cell phones that are listed - creating a weird loop. Without being able to test with you live I can only do so much but it wouldn't surprise me if what you're experiencing is simply a configuration issue that can easily be fixed :)
Photo of Habitatbuilder

Habitatbuilder

  • 80 Points 75 badge 2x thumb
I would be happy to let you test live with me--at my phone now. Do you need my main number or can I tell you to call me at the number ending in 3304 (ext. 101)? Not sure if this is a forum comment or an individual one. Thank you for your help!
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Habitatbuilder,

Unfortunately, I'm not part of the telephone support team, but if you call 1-800-898-4591, Option 3 - a support agent would be more than happy and able to assist you with this. You can even always refer them to this thread so they can get an idea of what's going on :)
Photo of John Walker

John Walker

  • 356 Points 250 badge 2x thumb
Yes, this is still happening for us as far as I know. I've just told my users in the call queues to stop using the mobile phone app.
(Edited)
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey John, can you give me a full breakdown of which call queue/user this is affecting? You can also give me extension numbers, it will help me narrow things down :)
Photo of JENNIFER BROGREN

JENNIFER BROGREN

  • 82 Points 75 badge 2x thumb
I could use some help with this also.  When I answer a call from a call queue (option 2 in our system) and attempt to transfer that call to extension 102, my own phone rings again.  We are all on mobiles, if that makes a difference.  I tried to sort it out with the phone support team yesterday but we didn't get anywhere.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Jennifer! Could you give me a Call Sample when this happened so I can take a look at it? :)
Photo of JENNIFER BROGREN

JENNIFER BROGREN

  • 82 Points 75 badge 2x thumb
Hi, Saadet!  Thank you for your email.  Looking at my call history, I believe this to be an accurate example.  Thank you in advance for your help!

Called Number: 859-533-9444
Calling Number: 830-387-2870, Option (Call Queue) 2
Date: January 18, 2018
Time and Time Zone: 4:25 PM GMT-06:00 (US Central Time)
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Jennifer,

Hmmm....based on that call sample I don't see anything that would explain the occurrence :( Does this happen everytime you go to transfer the call?

How are you transferring the call? 
Photo of JENNIFER BROGREN

JENNIFER BROGREN

  • 82 Points 75 badge 2x thumb
It only happens with queue calls.  If someone calls my extension I can transfer without a problem.  In both cases I transfer by entering ## 102.

The phone support folks replicated the problem on Thursday, if you can see anything in those records, but that was such a mess you probably won't be able to tell which test call it was.  
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hmmmm....strange! I'll follow up with the agent since your case is still open so they can gather fresh samples!
Photo of Suze Howe

Suze Howe

  • 80 Points 75 badge 2x thumb
I'm having the same issue! When I am on the Desktop App and Blind Transfer a call to another internal extension, it simultaneously rings the app on my mobile phone. 

I just ran a test and the first issue is that the call doesn't seem to be going directly to voicemail like it should be. It rang several times before going to voicemail and when I looked at the log it appeared to be doing a standard transfer instead of a blind transfer (which eventually went to voicemail because the recipient didn't pick up).

While the call is ringing the other extension, it is also ringing my extension on the mobile phone app. If I ignore the ringing, the call goes through, but it's really annoying and also not functioning the way it is supposed to!

My test call this morning was at 9:59am from 207-862-5669 to our office number at 207-866-3908. I selected our generic call option which goes to our support queue (#1), which then rang my extension (53). I picked up via my desktop app and then hit Blind Transfer to extension 50.  Both the extension and my mobile phone app rang for about 15 seconds (our standard ring time) before the call was put through to the voicemail for extension 50 at which point I hung up the call.

I hope you can figure out what is going on because it is really annoying! Thank you!
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
Hey Suze,

Thanks for providing that call sample. The call log doesn't show anything abnormal and I checked your settings (as well as extension 53) and nothing looks wrong/the reason for causing this behavior.

I spoke with a Tier 3 rep and we tested it just now - this is what we did:

1) First test was Ext 1 receiving a direct call on their hardphone, then transferring the call to Ext 3. Ext 1 had the mobile app up during this time. The call successfully transferred to Ext 3 without ringing Ext 1's mobile app.

2) Second test was Ext 1 received a call from the call queue - again on their hardphone. The call was then transferred to Ext 3. The call transferred over without ringing Ext 1's mobile app.

We were not able to replicate what you're experiencing :(

So! What happens when you try example 1 from above? Does this happen to you for every call (that comes into the call queue) that gets transferred to a different extension? Or just sometimes?
Photo of Suze Howe

Suze Howe

  • 80 Points 75 badge 2x thumb
Sorry, I think I didn't explain this well enough. I'm not having a problem with the desk phone (the hardphone) - the problem is when I answer the call using the app on my computer and try to transfer. When I do, it rings both the receipient's extension as well as the app on my mobile phone.

It may have something to do with having the app running in two different places? Or an issue with the Windows app?

This happens every time I try to transfer using the computer app.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,498 Points 50k badge 2x thumb
What version of the softphone and mobile app are you on, Suze?

I'm going to continue to test!
Photo of Suze Howe

Suze Howe

  • 80 Points 75 badge 2x thumb
The computer app is Windows version 9.3.5.28675 and the phone is Android version 9.4.2.1.7.  Thank you!
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,558 Points 50k badge 2x thumb
Official Response
Hey Suze!

Ok, so I found out that this is a known issue (semi-rare) and doesn't always occur for everyone. Which explains why I was able to replicate it on my test account but my Tier 3 colleague couldn't replicate it on their test account. 

So, what we need from you, Suze (and anyone else having this issue), is to open a case and include the following:

1) Call Sample (just like you did earlier - the most recent the better)
2) Debug logs for the softphone (if you don't feel comfortable the support agent can help you!)
3) Debug logs for the mobile app (same thing as I mentioned above)
4) JIRA IOS-23556 (for iOS mobile app) & JIRA AB-22338 (for Android mobile app)

The workaround at this time is to complete a warm transfer as opposed to the blind transfer.
Photo of Jason Darrough

Jason Darrough

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Transferring any call rings my cell phone.

Polycom VVX601 

We have an office setup and any time I transfer a call from my handset, either to an external number or another extension inside our network it also opens the RC app on my cell phone and rings. It still actually transfers the call to the intended number or extension but it rings my cell phone briefly, 2 times or so. I can see on the handset screen that it is ringing the other person at the same time. I'm the only one out of 15 users experiencing this. 

Anybody else had this or know what setting I need to change to stop it? Thank you. 
Photo of MS

MS

  • 112 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Transferred calls also show up on RingCentral phone app.

When transferring a phone call from a RingCentral handset (a PolyCom VVX201 model) to another user, it rings through the RingCentral app installed on my smartphone even after the call has connected to the other user. This occurs even after any other contact phone numbers are removed from my Call Handling/Forwarding settings, and the RC app is made inactive in Settings. Is there any explanation for this happening, or how to stop it from happening aside from uninstalling the app?

Thank you.
Photo of Daniel Huls

Daniel Huls

  • 66 Points
This is happening to us too.