My ring central VOIP phone we received won't get past startup menu

  • 0
  • 1
  • Question
  • Updated 3 weeks ago
My ring central VOIP phone we received plugged in attached to cat 5 cable with internet keeps displaying getting update and restarts never connecting or getting dial tone. I attached user to the phone what else can I do to get it to work 
Photo of Patrick Vansciver

Patrick Vansciver

  • 70 Points

Posted 3 weeks ago

  • 0
  • 1
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 17,334 Points 10k badge 2x thumb
2287 USA based users, 28 different sites,  3800 DID lines - all Polycom VVX500 phones

2018-10-23  It helps when you post in this forum - to detail what model of phone you are writing the request for info about.  It sounds like you may need to login to the web interface of the phone hardware and reset the SIP server for provisioning to the updated address.  

Doing this usually will allow the phone to pull its provisioning registration and firmware properly.
Photo of Bob Robinson

Bob Robinson, Champion

  • 2,066 Points 2k badge 2x thumb
If it's a RingCentral provided phone it should be set to look to the provisioning server on their end automatically.  If not, you'll need to alter the phone settings to point it to RC for provisioning and support can assist.  If the provisioning settings are right but it's not connecting, it could be something related to the network (bad port, bad patch cable, port or firewall settings, QoS not enabled).  If you have another network port to try, you can eliminate that as a possibility by plugging the network cable into another port and see what happens.
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 17,334 Points 10k badge 2x thumb
2018-10-23 Our firmware 5.6 update for all our Polycom phones has been in process for 2 nights in a row. Out of over 2000 Polycom VVX500 handsets in our system,  a few have come up with registration errors during their firmware update and have needed to be manually reset the way I mentioned above by resetting the SIP server address in the phone hardware.  This is why I suggested looking at the phone's web interface and seeing if a reset would allow the phone to finish its registration process at the RC server side.