Option to add "Voicemail" tab to bottom tab bar in place of unnecessary "Message" tab.

  • 0
  • 3
  • Idea
  • Updated 7 months ago
I switched to the new app today (was using RC Phone), and see there is a new Message tab at bottom I don't want or need to see. Now the Voicemail tab is gone at the bottom, because it has been moved into a "top tab bar" within the "Calls" bottom tab. This makes it difficult to quickly switch between recent calls and voicemails, as the top tab bar is impossible to reach one handed. So I would like the bottom tab bar to be CUSTOMIZED so it looks and works like the older RC Phone app.

The new RingCentral app is becoming the "iTunes" of phone apps. I mean, how many features are going do be shoehorned into a single app? Soon we'll have a music streaming tab? Maybe some games to pass the time? A "dating service" tab maybe? :-/

Put simply: Option to hide the Messages tab, and restore the Voicemail tab within the bottom tab bar.

Key Points:

* We bought RingCentral for one purpose: PHONE CALLS! The old "RC Phone" app was perfect. I don't need to see a "Team Messaging" tab that is wasting space in a "Phone" application.

* Voicemail is a key PHONE feature, and now it is BURIED in a hard to access place. This is a usability issue, especially when using the app one-handed where your thumb can't reach the "top tab bar", which makes the functionality convoluted.

* It only make sense to have the Voicemail tab reappear automatically when the Messages tab is (hopefully) hidden, as there will be space for it then!


Photo of How Do I Hide Messages Tab And Add Voicemail Tab?

Posted 7 months ago

  • 0
  • 3
Photo of Chris Criner

Chris Criner

  • 288 Points 250 badge 2x thumb
Completely agree! Also, I have both the Phone App & the RC app on my work phone, as I try to get used to the RC before the Phone app goes away. In the Phone app, I could long press a text and would get an option to "Forward" so I could text to another person. The RC app only allows "Copy", so you now have an extra step to have to open a new text window, and paste it in. ugh