Outbound Caller ID for Texts still not working

  • 0
  • 1
  • Question
  • Updated 3 weeks ago
  • Acknowledged
Since the recent update for the new RC desktop app from 19.8.1 to 19.9.1, the new Outbound Caller ID for Texts preference does not appear to work. It doesn't seem to matter which Outbound Caller ID I select for Texts, the texts always come from the same main company number just like they did before. I have tried multiple contacts and switched between main and direct numbers, I signed out of all apps and signed back in and the ability to send a text from another number still doesn't appear to work. Anyone else having this problem?

Photo of ACCOUNT

ACCOUNT

  • 2,148 Points 2k badge 2x thumb

Posted 2 months ago

  • 0
  • 1
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 8,314 Points 5k badge 2x thumb
Hi ACCOUNT, 

We haven't seen any other reports of this, I would open a case with Tech Support! 

Open support case online  
Photo of ACCOUNT

ACCOUNT

  • 2,148 Points 2k badge 2x thumb
You also haven't seen any reports saying the option is working.

I put in a case 5 days ago. Customer service told me today that I must have download the wrong app and then closed the case.

The Outbound Caller ID  for Texts does not work. Have you tried it?

Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 8,314 Points 5k badge 2x thumb
We've heard success stories internally regarding this feature. Can you confirm if all of the the following apply to your account: 

• You need to have more than one phone number assigned to the extension in order to select an alternate caller ID.
• Only local numbers are allowed to send and receive SMS.
• To check your options as caller ID, log on to your online account and check if you have a local number.  All local numbers assigned to the auto receptionist can only be used to send and receive SMS by the operator extension.
• Numbers assigned to other extensions cannot be used as caller ID.

All these qualifiers are listed in the KB article for how to Use an Alternate SMS Caller ID When Sending a Message. 
Photo of ACCOUNT

ACCOUNT

  • 2,148 Points 2k badge 2x thumb
The older RingCentral Phone desktop app's option to select my Main Company number or my Direct Number or the 'Blocked' option has been working correctly for me for over a year. Outbound Texts show the correct number according to what is selected in the Settings. I would assume that since the older app's option has always worked for me, my current RC account is indeed meeting all of the requirements for the Outbound Caller ID for Texts to function properly no matter which app I use.



However, I will do my best to respond the list of requirements you have posted to the best of my knowledge:

You need to have more than one phone number assigned to the extension in order to select an alternate caller ID.

I have 2 phone numbers. 1 Main Company Number and 1 Direct Number. The Direct Number is assigned to extension 101. The Main Company Number does not have an extension as far as I am aware.

Only local numbers are allowed to send and receive SMS

I assume this means only non-800 numbers. Both phone numbers I have can currently send and receive SMS through the older RingCentral Phone desktop app just fine. Neither are 800 or Toll Free numbers.

To check your options as caller ID, log on to your online account and check if you have a local number.  All local numbers assigned to the auto receptionist can only be used to send and receive SMS by the operator extension.

In the Admin Portal online, I have 1 Main Company Number under the Company tab and 1 Direct Number under the Assigned tab. IVR Settings show extention 101 assigned to my Direct Number.

Numbers assigned to other extensions cannot be used as caller ID

I do not currently have any other extention, besides ext 101, in use or assigned to anything.

-------------------

Both my Main company number and my Direct number are able to be selected in the new RingCentral desktop app as shown below. However, no matter which number I select, the Outbound ID used for sending texts from the new RingCentral desktop app remains as the Direct number. All texts received to my customers from the new RingCentral desktop app appear with the Direct Number ID, even when the Main Company number is selected.





Photo of ACCOUNT

ACCOUNT

  • 2,148 Points 2k badge 2x thumb
Texting from the Main Company number in the RC app still does not work, even when signed in as the Operator. I have put in 4 New Cases:

Case Number: 09415626 (put in 19 days ago)
Case Number: 09431257 (put in 17 days ago)
Case Number: 09448452 (put in 13 days ago)
Case Number: 09497518 (put in 6 days ago)

And still no one responds.

(Edited)
Photo of ACCOUNT

ACCOUNT

  • 2,148 Points 2k badge 2x thumb
This reply was created from a merged topic originally titled Texting from Main Company number in RC desktop app does not work.

Since the recent update for the RingCentral desktop app from 19.8.1 to 19.9.1, setting the new Outbound Caller ID for Texts option to your Main Company number does not work. The option is visible and selectable, but will not send SMS from your Main Company number. Texting from the Main Company number works from the RC Phone app and the RC SMS API but does not work from the new RC desktop app, even if you are working from the operator extension.

Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 67,700 Points 50k badge 2x thumb
Hi ACCOUNT,

I wanted to provide an update. We are experiencing a slight snag with the ability for the Company Fax/SMS Recipient to change their outbound SMS ID to the main number and for this change to be obeyed. Our Product Team is aware that this is not working properly and looking into it. You can open a case and include JIRA GLIP-25850 in your notes. You'll receive an update when the issue has been fixed.